Problem of auxiliary power supply_REF62WFLY1700VSiC

Announcements

Live Webinar: Solving the challenges in xEV power conversions | March 7 @9am & 5pm CET. Register now!

Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

cross mob
lock attach
Attachments are accessible only for community members.
JasonLEE
Level 5
Level 5
100 replies posted 250 sign-ins First like received

power.png

I looked at this reference design and designed the aux power board in the same way.
I also have this EVAL board.
I found a problem with this EVAL board.

1. It has been confirmed that only 16V is output to the 24V output terminal.
2. The 15V output terminal does not generate output, it is just 0V.
3. EVAL board and custom board designed with reference to this EVAL board show the same problem.
The biggest problem is where the LED blinks. I attached a video.
The voltage is very abnormal.
4. I checked by removing all the components one by one, but no problem was found.
5. What's unique is that 10 of these customized boards were produced, but only two worked normally and eight were defective. The components and designs are all the same. I have no idea why. Something is wrong with the eval board.
6. And I have a question.
What does -15v mean?
I know +15v as an output, but I don't quite understand what -15v means.

-15.png

 

 

However, this mosfet fails to power on and continues to show strange reactions.
I just can't find the cause.
It should work well after the power is turned on, but it will not continue to power on.


I attached a video and a schematic, so please check it.

0 Likes
1 Solution
AZIZ_HASSAN
Moderator
Moderator
Moderator
5 likes given 250 sign-ins 100 solutions authored

Hello,

Sorry to say that you got some problem with Eval board as well but its something I am not able to understand as how eval board is not working fine. To analyze it further, I request you to share the Vge, VDD pin and out put voltage waveforms in one screen.

Thanks

BR

AZIZ

View solution in original post

0 Likes
3 Replies
AZIZ_HASSAN
Moderator
Moderator
Moderator
5 likes given 250 sign-ins 100 solutions authored

Hello,

Thank you for posting at Infineon community.

Give me some time to come back.

Thanks

BR

AZIZ

 

0 Likes
JasonLEE
Level 5
Level 5
100 replies posted 250 sign-ins First like received

@AZIZ_HASSAN 

Hi,

Yes.

I want to solve thie problem.

I will wait your come back.

0 Likes
AZIZ_HASSAN
Moderator
Moderator
Moderator
5 likes given 250 sign-ins 100 solutions authored

Hello,

Sorry to say that you got some problem with Eval board as well but its something I am not able to understand as how eval board is not working fine. To analyze it further, I request you to share the Vge, VDD pin and out put voltage waveforms in one screen.

Thanks

BR

AZIZ

0 Likes