Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

MOSFET (Si/SiC) Forum Discussions

hugoc
Level 1
10 sign-ins 5 sign-ins First reply posted
Level 1

Hello, 

I am attempting to import the 1200 V Infineon device models into Matlab Simulink using 'subcircuit2ssc', however when I attempt to in Matlab I get the error:

"Subcircuit delimiters is not in expected format.

Error in spiceSubckt

Error in subcircuit2ssc"

I have changed the numbers such as MEGA to 1e9 etc and ** to ^ to match Matlab use but still get the same errors. Any suggestions on other sections of the .lib to change in order to make it work with subcircuit2ssc would be much appreciated.

The original model code is attached below.

 

0 Likes
1 Solution
Abhilash_P
Moderator
Moderator 25 likes received 250 replies posted 250 sign-ins
Moderator

Hi,

 

   Thank you for posting on the Infineon Developer Community. 

 

The attached simulation model is tested on Simetrix, an Infineon Simulation software. 

The Simulink/Systemec model has to be used in Matlab | Simulink platform. Please contact regional office to get this model. If you face any difficulties in getting the model, please do let me know. I will help you with it. 

 

Regards,

Abhilash P

 

View solution in original post

0 Likes
3 Replies
Abhilash_P
Moderator
Moderator 25 likes received 250 replies posted 250 sign-ins
Moderator

Hi,

 

   Thank you for posting on the Infineon Developer Community. 

 

The attached simulation model is tested on Simetrix, an Infineon Simulation software. 

The Simulink/Systemec model has to be used in Matlab | Simulink platform. Please contact regional office to get this model. If you face any difficulties in getting the model, please do let me know. I will help you with it. 

 

Regards,

Abhilash P

 

0 Likes
hugoc
Level 1
10 sign-ins 5 sign-ins First reply posted
Level 1

Hello Abhilash,

Thankyou very much for your response, I have done as you suggested and submitted a technical assistance form (which I believe gets sent to my regional office) but I have been told that I cannot get the Simulink/Systemec model- do you have any further suggestions for my problem?

Best wishes,

Hugo

0 Likes
Abhilash_P
Moderator
Moderator 25 likes received 250 replies posted 250 sign-ins
Moderator

Hi Hugo,

 

   I will try looking it internally. 

Regards,

Abhilash P

0 Likes