Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

cross mob

Issue with Cypress Programmer 4.2 on Ubuntu – KBA237970

Issue with Cypress Programmer 4.2 on Ubuntu – KBA237970

Infineon_Team
Employee
Employee
50 replies posted 25 likes received 25 replies posted

Problem:

Cypress Programmer 4.2 cannot be launched on a clean install of Ubuntu for all supported versions.

Background:

Previous versions of Cypress Programmer 3.0/4.0/4.1 launch correctly on clean Ubuntu installations.

This issue appeared after migration from Qt 5.10, to Qt 5.15, which requires libxcb 1.11 to be installed (https://doc.qt.io/qt-5/linux-requirements.html). The required package libxcb-xinerama0 is missing.

Solution:

Run the following command to install the prerequisite package:

sudo apt install libxcb-xinerama0

0 Likes
64 Views