IR2113, IGBT, Dead time lose

Announcements

From sunburn to sun earn – we’ve got the power! Watch our #poweringgreen videos now.

Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

cross mob
erabalf
Level 1
Level 1
5 sign-ins First reply posted First question asked

Hi Infineon community

My name is Alfredo, I am trying to set up a DC-AC Driver, I am using a MCU, IR2113 (as bootstrap Driver) and IGBT GB10B60kD

My circuit has a less one issue, gate signal from IR2113 it loses the dead time when PWM1 (falling edge) IGBT high side, please ,see the next picture, this is tje schematic used:

erabalf_0-1667254369297.png

And here, there some pictures where I  tryed to show you the issue: the issue is showed in Test Point C (ar IGBT Gate)

But i am showing some previus steps in order to show you when the issue is located

Please, check nect pictures:

next picture: Test Point A (PMW 1 and PWM 1 complementary, please see the deadtime)

at this poiny, MCU sends PWM signal, as PWM1 and PWM 1 complementary.

erabalf_1-1667254399793.png

 

 

next picture:

Test Point B: PWM1 and complementary after Opto Driver, Signals are LIN and HIN IR2113.

erabalf_2-1667254434881.png

 

Test pint C: IR2113—IGBT Gates, here We can see deadtime (when PWM1 is falling edge) it lose.

erabalf_3-1667254475799.png

 

 

next picture:

 If I turn off the DC-LINK, we can see duty cycle BUT there is an small error, I guess it is the same when DC-LINK is ON, and the voltage is add….

erabalf_4-1667254505897.png

 

next picture: And this is the Half-bridge output (Test Point D):

erabalf_5-1667254538227.png

Any help/comment/advice to understan why DEAD Time is lose in gate for IGBT High side, low side look fine.

Best regard
Alfredo

 

 

 

0 Likes
1 Solution
Xiangrui
Moderator
Moderator
Moderator
500 replies posted 250 solutions authored 50 likes received

Hi Alfredo,

Thanks for using Infineon Community. 

1. " If I turn off the DC-LINK, we can see duty cycle BUT there is an small error" 

This is because there is no load in your circuit. The voltage raises up because of parasite parameters.

2. "Test pint C: IR2113—IGBT Gates, here We can see deadtime (when PWM1 is falling edge) it lose."

This is because you test the potential at point C. But don't forget there is a floating voltage at high side. It means you have added 30V here when DC ON. So actually, it works well. It is also confirmed by your Half-bridge output.

BR,

Xiangrui

View solution in original post

0 Likes
2 Replies
Xiangrui
Moderator
Moderator
Moderator
500 replies posted 250 solutions authored 50 likes received

Hi Alfredo,

Thanks for using Infineon Community. 

1. " If I turn off the DC-LINK, we can see duty cycle BUT there is an small error" 

This is because there is no load in your circuit. The voltage raises up because of parasite parameters.

2. "Test pint C: IR2113—IGBT Gates, here We can see deadtime (when PWM1 is falling edge) it lose."

This is because you test the potential at point C. But don't forget there is a floating voltage at high side. It means you have added 30V here when DC ON. So actually, it works well. It is also confirmed by your Half-bridge output.

BR,

Xiangrui

0 Likes

Hi 

Hi Hiangrui
Thanks a lot for your answer.
According your answer, it is ok, so, there is not any short circuit, I was thinking that maybe there was a short circuit  as in a small period of time, gates are active at the same time.
SO, again, thanks for your answer.
Best regard
Alfredo

 
0 Likes