Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

Hyper Flash Forum Discussions

yodo_4825591
Level 3
10 replies posted 10 sign-ins 5 replies posted
Level 3
Hi,
 
When I use s26kl512s hyperflash model, i meet some problem about  < word program command > .
 
 
yodo_4825591_1-1627538745473.png

 

 
I send command as below: the Status_reg[7] is always 1 indicating that flash is in ready state.
 
yodo_4825591_2-1627538745474.png

 

After CS de-asserted, Status_reg[7] always is 1.
yodo_4825591_3-1627538745474.png

 

 
As i known, when i send word program command, the Status_reg[7] shall be 0 to indicate flash busy.
 
How this happened? and what problem is in my command sequences?

 

 

Thanks

0 Likes
1 Solution
yodo_4825591
Level 3
10 replies posted 10 sign-ins 5 replies posted
Level 3

Oh,  I found my third transaction 's address is 0x55, but  right address is 0x555.

I have solved the problem.

Thanks. 

View solution in original post

0 Likes
2 Replies
BushraH_91
Moderator
Moderator 250 solutions authored First comment on blog 500 replies posted
Moderator

Hello,

Thank you for contacting Cypress Technical Support, an Infineon Technologies Company. Currently we are viewing your issue and will get back to you as soon as we find the resolution.

Thank you

Regards,

Bushra

0 Likes
yodo_4825591
Level 3
10 replies posted 10 sign-ins 5 replies posted
Level 3

Oh,  I found my third transaction 's address is 0x55, but  right address is 0x555.

I have solved the problem.

Thanks. 

0 Likes