Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

Hyper Flash Forum Discussions

ABC
Level 1
5 sign-ins First reply posted First question asked
Level 1

Hyperflash is not responding to any commands except status register read. I tried word programming , buffer programming, sector erase, Chip erase, DeviceID reading but none of this worked. Everytime status register value remains 0x80.

 

Can someone tell me what could be the issue.?

 

 

0 Likes
7 Replies
AS_36
Moderator
Moderator 500 replies posted 250 solutions authored 250 replies posted
Moderator

Hi,

Can you please tell the complete part number of the hyperflash device that you are using and the exact sequence of commands that are working and failing.

Regards.

0 Likes
ABC
Level 1
5 sign-ins First reply posted First question asked
Level 1

Hi, 

Thanks for the response.

 

PN: S26KS512SDPBHI020

Please see the attached image for commands used. 

 

HyperFlash3.jpg

 

Even word programming and buffer programming do not work. 

I get 0x48E5 every time I try to read from base address except in status register read(0x80). 

 

0 Likes
AS_36
Moderator
Moderator 500 replies posted 250 solutions authored 250 replies posted
Moderator

Hi,

  • Could you please confirm that the device has been initialized properly? Are you following the recommended power-up sequence? Please see page 79 & 80 of the datasheet for the recommended sequence.
  • Could you please confirm that there are no issues related to your setup? Is it possible for you to provide logic analyzer trace for status register read and device ID read?

Regards. 

0 Likes
ABC
Level 1
5 sign-ins First reply posted First question asked
Level 1

Hi, 

Thanks for the reply.

 

PFA images of status register read and device ID read. Device ID failedDevice ID failedSR failedSR failedSR passedSR passed

Frequency used: 1. Ref_clk and AXI-clk: 200MHz  2. clk0,clk90,clk180,clk270 : 100MHz.  Please look into attached ILA files if images are not clear. 

 

0 Likes
AlbertB_56
Moderator
Moderator 50 likes received 250 replies posted 250 sign-ins
Moderator

Hello,

Please find attached the response from (HyperBus) Applications Engineering:

  1. In Write operation: CA2 =0x 6005(in waveform); CA2 = 0x0005(In datasheet). In read operation also 0x60 is present. Is this acceptable?

The 0x60 is an artifact from HyperBus controller design. It is harmless and acceptable to the HyperBus memories.

  1. When I tried to read from address 0x123457, values mentioned in datasheet and waveform are different. Any issues here?

Can you try:

ValueRead = *( ( (volatile u16 *)0x20000000 ) + 0x123457);

 

Best regards,

Albert

Cypress Semiconductor Corp.

An Infineon Technologies Company

 

 

0 Likes
ABC
Level 1
5 sign-ins First reply posted First question asked
Level 1

Hi Albert,

Your reply is not matching with query I asked in this thread.

0 Likes
AS_36
Moderator
Moderator 500 replies posted 250 solutions authored 250 replies posted
Moderator

Hi,

Apologies for the long delay in responding. Due to some internal issues, this thread got missed.

Could you please let me know the latest update in this issue? Is it possible for you to provide the waveforms of the following signals - 

  • RPC_CK
  • RPC_CK_N
  • RPC_DQ[7:0]
  • RPC_CS_N

We will be needing it for better understanding of the problem.

Regards.

0 Likes