Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

DAVE™ Forum Discussions

Not applicable
I can't creat any of the Dave Projects in my virtual Maschine (vmware ). It's a Windows 7 64 bit System.
The Problem is that I can insert like in the screenshot.

the button "next" is schwitching from gray to a black text (the button is enabled)

I can press the button and nothing is Happening.

I don't get the next page "Microcontroller Selection Page"
I get this page only on my pc ouside of the virtual machine. I installed the same Dave Version on my normal pc.

I'm using all the time my virtual machine to develop my stuff

hopefully somebody can give me an Fastback.
Only in my virtual machine I'm using my svn system

1566.attach


thanks a lot
0 Likes
11 Replies
Not applicable
Hi Thomas,

The problem seems to be related to your DAVE project workspace. It happens when launching old workspace (that is created using older version of DAVE) inside new DAVE v4.1.2. From the image, I could see that you are using DAVE v4.1.2.

Can you please try to start a new workspace in DAVE. It should work.

Regards,
Daryl 🙂
0 Likes
Not applicable
thanks for the fast response.
I tried your work arround. Different folder locations
But the same issue 😞

I had before in the virtual machine running the Dave 4 beta version. This was running fine. I uninstalled the beta version before I installed the live version

Actuallly it's really frustrated for me because on my normal PC I can create the project but I can't implement an app because I'm using Kaspersky antivirus and this make problems with the solver 😞
In my virtual machine I can't create a project.

What can I do now?? I have to create asap a project because we would like to use the controller on a project that is already in production.
2000 pcb's with your controller 🙂
0 Likes
ningareddy_moda
Employee
Employee
FYI

In latest version of "Kaspersky Total Security-Version[16.0.0.614.0.17.0]", DAVE is functioning as expected.

We don’t know what changes they have done in the newer version, but when verified with latest "Kaspersky Total Security-Version: 16.0.0.614.0.17.0", we did not see the issue any more


Regarding the issue you are facing:

Can you please send us the .log file present in /.metadata/.log?
0 Likes
Not applicable
on my normal pc with windows 7 pro (64 Bit) have the same issue as in this link:
http://www.infineonforums.com/threads/3279-Not-able-to-add-apps-to-Dave-4.1.2

but I have the latest version of "Kaspersky Small Office Security 4. This is programm version 15.02.361(c)
the same issue. The solver is stucking all the time until I'm adding an app.

thanks
0 Likes
Not applicable
http://www.infineonforums.com/threads/3279-Not-able-to-add-apps-to-Dave-4.1.2

I have the same issue on my normal PC.
But with Kaspersky Small Office Security 4. Latest version 14.0.2.361(c)
0 Likes
Not applicable
thanks for your help.

the problem wasn't the Kaspersky for this issue.
It was related to no device lib.

I installed the device lib and now I can work correctly.

the questions is only why the installation in my virtual machine was without device lib and on my normal pc with device lib.
It was installed with the same setup routine file

thanks for your help.

you can close this ticket now
0 Likes
User10958
Level 1
Level 1
I experienced the same issue with Xubuntu Linux 15.10 + Virtualbox 5.0.8 + Windows 7 64bit + Dave 4.1.4 and never touched Kaspersky.
The solution to this problem was to install the missing device lib - thanks!

1709.attach

BTW, while clicking on the mentioned "Next" button (first post) when trying to launch a project, this error can be observed:


null
org.eclipse.ui
Error
Sun Dec 20 00:09:08 CET 2015
Unhandled event loop exception

java.lang.IllegalStateException: DaveDeviceDataAccessor cannot be null
at com.dave.common.widgets.mcu.DaveMcuWidgetProvider.getComposite(DaveMcuWidgetProvider.java:92)
at com.ifx.dave.project.creator.MCUSelectionPageForNewProject.createControl(MCUSelectionPageForNewProject.java:123)
at org.eclipse.jface.wizard.WizardDialog.updateForPage(WizardDialog.java:1276)
at org.eclipse.jface.wizard.WizardDialog.access$4(WizardDialog.java:1268)
at org.eclipse.jface.wizard.WizardDialog$8.run(WizardDialog.java:1257)
at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator.java:70)
at org.eclipse.jface.wizard.WizardDialog.showPage(WizardDialog.java:1254)
at org.eclipse.jface.wizard.WizardDialog.nextPressed(WizardDialog.java:942)
at org.eclipse.jface.wizard.WizardDialog.buttonPressed(WizardDialog.java:434)
at org.eclipse.jface.dialogs.Dialog$2.widgetSelected(Dialog.java:619)
at org.eclipse.swt.widgets.TypedListener.handleEvent(TypedListener.java:248)
at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
at org.eclipse.swt.widgets.Display.sendEvent(Display.java:4353)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1061)
at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:4172)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3761)
at org.eclipse.jface.window.Window.runEventLoop(Window.java:832)
at org.eclipse.jface.window.Window.open(Window.java:808)
at org.eclipse.ui.internal.actions.NewWizardShortcutAction.run(NewWizardShortcutAction.java:136)
at org.eclipse.jface.action.Action.runWithEvent(Action.java:519)
at org.eclipse.jface.action.ActionContributionItem.handleWidgetSelection(ActionContributionItem.java:595)
at org.eclipse.jface.action.ActionContributionItem.access$2(ActionContributionItem.java:511)
at org.eclipse.jface.action.ActionContributionItem$5.handleEvent(ActionContributionItem.java:420)
at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
at org.eclipse.swt.widgets.Display.sendEvent(Display.java:4353)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1061)
at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:4172)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3761)
at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$9.run(PartRenderingEngine.java:1151)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:1032)
at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:148)
at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:636)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:579)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:150)
at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:135)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:380)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:235)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:648)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:603)
at org.eclipse.equinox.launcher.Main.run(Main.java:1465)


A reason for the missing lib(s) could be that the VM might not have had Internet access during the installation. However I am not sure about that and could not reproduce the problem.
0 Likes
WilhelmBrezovit
Employee
Employee
Welcome! 10 replies posted 5 replies posted
Thank you very much Rafael! 🙂
0 Likes
User20060
Level 1
Level 1
0 Likes
thebacklinkking
Level 1
Level 1
First reply posted Welcome!

Thank you for sharing, this was very useful! 

Tree Service Denver

Lilly white crested gecko for sale

Reptile store Denver

 

 

0 Likes