Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

Not applicable

I'm trying to send data to my XMC4500 relax kit over UART. For this I want an interrupt function to be called when a certain amount of bytes are in the FIFO buffer. To do this I use the following config:
When I click solve & save, everything is OK. However, when I generate the code, the signal connection just disappears, without an error or a warning. Does anyone know what the problem could be?

thanks in advance.
2 Replies
Not applicable

Sorry I couldn't see clearly which signal from UART001 App you have selected to connect to NVIC002 App.
However, I have no problem to make the connection from UART001[1.0.24] "FIFO Receive Buffer Interrupt" to NVIC002[1.0.28] "Interrupt Node". Even after "Solve And Save" and "Generate Code", the signal connection is still there which is same as the image (H/W Connectivity View) you provided. My project is built for XMC4500.
Would you pls show me a snap shot of the error (the signal connection just disappears) you got?

Best regards,
Not applicable
I did not get any error at all. Anyway, I solved the problem by just starting over with a new project. It works now.

Thank you for your time.