Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

DAVE™ Forum Discussions

ipek
Level 4
Level 4
25 replies posted 10 replies posted 10 questions asked
Hi,

I was trying to create a new project in a workspace. I have done this million times before.
But today I am having a trouble now. I am doing File->New->DAVE Project. I wrote the Project Name and select a Project Type and Tool Chain. But neither the button Next, not Finish becomes available.
I cannot click on them.

Then I look a little more. I checked the Properties of a project in this workspace. I saw that Microcontroller Info in Properties -> C/C++ Build is missing.
When I click to that line I get this error: Could Not Accept Changes: The currently displayed page contains invalid values.

In another workspace that everything is fine, I checked the same property and Microcontroller Info was there.

How can I restore this information in that corrupted workspace?

Bests,
İpek
0 Likes
1 Solution
ipek
Level 4
Level 4
25 replies posted 10 replies posted 10 questions asked
Hi All,
I solved it.
I think this microcontroller info is defined in a file called D_LibraryStore4_4. Sone how its path is changed that's why IDE cannot find it.
To solve the problem, I fixed the path. And this path was written in org.eclipse.ui.prefs file which is located in the project's .metada/.plugins/ file.

View solution in original post

0 Likes
4 Replies
Vasanth
Moderator
Moderator
Moderator
250 sign-ins 500 solutions authored First question asked
Hi Ipek,

Are you seeing this issue for the same device on different projects ? Are these projects created the set of steps ?

You can also try updating the device support by,
Press: -> Help -> Check for DAVE APP Updates (Device Description updates and Device Pack update)

Additionally to make sure that you use latest Dave version, install DAVE 4.5.0 is from the Infineon Toolbox.

Best Regards,
Vasanth
0 Likes
ipek
Level 4
Level 4
25 replies posted 10 replies posted 10 questions asked
Hi Vasanth,

These methods you are suggesting are independent from my problem.
I am asking, where is this IDE getting "Microcontroller Info".
For those who may live the same problem, If I recreate the workspace(by deleting the metadata folder and making DAVE create a new one), problem is solved, it is not a solution but at least I can continue to work..
By the way I update my Dave to 4.5 and nothing is changed.
0 Likes
ipek
Level 4
Level 4
25 replies posted 10 replies posted 10 questions asked
Hi All,
I solved it.
I think this microcontroller info is defined in a file called D_LibraryStore4_4. Sone how its path is changed that's why IDE cannot find it.
To solve the problem, I fixed the path. And this path was written in org.eclipse.ui.prefs file which is located in the project's .metada/.plugins/ file.
0 Likes
Vasanth
Moderator
Moderator
Moderator
250 sign-ins 500 solutions authored First question asked
Hi Ipek,

Thanks for sharing the solution.

Best Regards,
Vasanth
0 Likes