Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

DAVE™ Forum Discussions

trinigrinspan
Level 1
Level 1
First reply posted First question asked Welcome!

To begin programming my development board that has an XMC1302, I downloaded DAVE, SEGGER J-Link, and MemTools. I initially tried programming by configuring things in the DAVE debug settings, like changing the executable lines for the GDB J-Link. After, I tried going into the SEGGER J-Link files and attempting to dictate what device I am trying to program to. As of right now, I am working with MemTools, changing the BMI, and trying to switch it out of its default asc_bsl to the debug state. In Dave, the debugger is saying that I am still not in the right BMI, and when trying to compile and debug the code, I am running into the error that says "Could not determine GDB Version after sending," which I had set it as J-Link GDB ServerCL. Any advice on how to fix this?

Thanks. 

0 Likes
2 Replies
Vasanth
Moderator
Moderator
Moderator
250 sign-ins 500 solutions authored First question asked

Hi,

Can you check few things.

If you have multiple versions of GDB ?

If your company's network block GDB server?

Also see a similar thread on MTB on a similar issue. Let us know your observations.

Best Regards,
Vasanth

0 Likes

Hi. 

I checked, I believe I only have one GDB version. When trying to use Dave, I still get the error Could not determine GDB Version after sending. Do you know what paths my executable lines should be referencing to in the Dave debug window? 

0 Likes