Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

DAVE™ Forum Discussions

Not applicable
Hi. I've been successfully using the following DAVE example project, on an XMC4300 board:

XMC4300 EtherCAT APP SSC Slave Example V2.1

I can see the example uses an 'ECAT_SSC [4.0.8]' APP. In the 'Add New APP' dialogue, it's listed under the Communication > Industrial category.

However, if I start a new DAVE project, XMC4700 based, I don't have that category.

I've tried everything I've read online and within DAVE, about adding a new APP. Going via 'Help > Install DAVE APP/Example/Device Library...'
But the ECAT_SSC APP is nowhere to be found. It doesn't exist within the UpdateSiteDAVEApps_1_0_66.zip I've downloaded (252GB).
And following the online Infineon instructions to install those APPs locally for use, failed anyway, with file not found errors on every APP..

Within the example project, 'Help > Uninstall DAVE APP/Example/Device Library...' lists the ECAT_SSC APP,
and gives the URI as 'http://resources/DaveAppLibrary/XMC4000/ECAT_SSC'. Within my new project, trying to install ECAT_SSC from that location, fails.

I've also tried switching the example project from XMC4300 to XMC4700, which is all I really want to do. However, the DAVE Project Upgrade > Device Migration,
lists no other available devices as migration targets. Hence, the attempt to create a new project, XMC4700-based.

I've searched the DAVE Forum and the web generally for any further insights, without luck.

Any ideas?

Thanks!

David King
0 Likes
2 Replies
RSKearney
Employee
Employee
Hi David,
You need to use the XMC4800, the XMC4700 is the same part with the EtherCAT disabled.
0 Likes
Not applicable
Ah, thanks Robert, newbie error!
0 Likes