Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

DAVE™ Forum Discussions

Not applicable
0 Likes
12 Replies
Not applicable
Hi,

You need to click "Generate Code" button 1st before doing the compilation.
0 Likes
User7795
Level 4
Level 4
Hi,
the grey background of the source window indicates, you are trying to compile a not active project.
First set the project you want to compile to active by: mouse on project directory, right click, select "Set Active Project". Source window background color now changes to your setting (mostly white).
0 Likes
Not applicable
If I donot click "Generate Code" Button, the source of right is unlikely to occur
0 Likes
Not applicable
Hi,
I first create a project, appears "Can not find " errors at compile time , and then call the routine of Infineon 's examples , compile, found the error is the same, when the hair on the screenshot in Figure directly from infineon examples
0 Likes
User7795
Level 4
Level 4
Hi wforest68,

to start a new C project as DAVE CE project use the following procedure:

- Create a new project with File > New > DAVE Project > DAVE CE project
- Enter your project name and click Next
- Select yout target device and click Finish

Now you see in the C/C++ Project window (at top left) your created new project.
Open the project folder by a click on it and click also on Main.c. Main.c is opened in the source window.

When you now start a compilation you will get the error message:
../Main.c:12:90: fatal error: DAVE3.h: No such file or directory
because file DAVE3.h still doesn't exist.

To generate this file start DAVE > Generate Code
which generates file DAVE3.h in your project directory at Dave/Generated/inc/DAVESupport/.
Now your project is ready to compile with success and the final message in the console window after many others will be (the name of my project was 'Test'):

text data bss dec hex filename
5348 4 2060 7412 1cf4 Test.elf
Finished building: Test.siz

**** Build Finished ****

That's all. Look on the screeshot.
If you still get error messages some of your ide settings are wrong.

Best regards
0 Likes
Not applicable
Hi, lng99

Thanks your reply

I have used DAVE 3.1.8, I have to use DAVE experience.
The question now is , after generating code , compile error , see below:
625.attach
0 Likes
User7795
Level 4
Level 4
Hi wforest68,

check your settings at Project -> Properties and compare to the settings on the screenshots of my installation of Dave3.1.8.

Best Regards
0 Likes
Not applicable
Hi lng99,

My setting at Project -> Properties and compare to the settings on the screenshots is :

Thanks your reply
640.attach641.attach
0 Likes
Not applicable
Hi Ing99,

I install DAVE 3.1 10 had previously been installed DAVE 3.1 8, and I think I now have the error may have something to do with that, but I don't know what error.

Best Regards
0 Likes
Not applicable
Hi,

Did you use "DAVE™ version 3.1.10 installer" to install DAVE 3.1.10?

BR,
Zain
0 Likes
Not applicable
Problem solving because a character is DAVE ignores the project directory
0 Likes
Not applicable
hello everybody,

i installed today Dave 3.1.10 and wanted to build my project. I followed the steps you told before which i already knew from Dave 3.1.6, but now its not working. After generating the code no "Dave3.h" is created.
what should i do or can i do? .. I have installed it right away, chose my preferred working directory (which is not the standard directory suggested by Dave) and that it was. Haven't changed anything. And yes i used the Dave Installer packaged provided by Infineon.
Even the project examples don't work which tells me that a setting of Dave must be wrong but which?
Hope you can help.

Best regards

Edit: found the problem: I'm using Win8 and my profile is "user_000". For the code generation this underscore "_" makes the problem. Moved the workspace somewhere else.
0 Likes