Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

Problem using spice model with Altium

Not applicable
Hello,

I am presently trying to simulate one of the high speed 5 IGBT with Altium designer. I tried it with the demo version of SIMetrix and it works perfectly, as it was design to work with this simulator.

My problem is when I try to use it with Altium Version 13.2.5. The model I'm using is IKW50N65F5_L2.

I also tried the MOSFET model IPZ65R045C7, both the level 0 and the level 1 model. Only the level 0 works. It appears that as soon as some parameters are tunable, it doesn't work. The problem is similar with the IGBT. The specific error I get for the IGBT is the following:

Class Document Source Message Time Date No.

[Error] Test.SchDoc AdvSim XQ1 - Expected parameter name 2:39:40 PM 2014-09-18 5


The first line of the model is as follow:
.SUBCKT IkW50N65F5_L2 anol gate katl PARAMS: TJ = 27

Since it appears to be unable to find a certain parameter, I then tried to simply remove the space in the assignation:
.SUBCKT IkW50N65F5_L2 anol gate katl PARAMS: TJ=27

At that point, it recognized the parameter and it became tunable. But then I get many others errors like this:

Class Document Source Message Time Date No.

[Error] Test XSpice Error on line 94: gic\xl73xxf5\xq1 di\xl73xxf5\xq1 ds\xl73xxf5\xq1 value = {limhyp\xl73xxf5\xq1 (ipc\xl73xxf5\xq1 (i(vinc\xl73xxf5\xq1), v(b\xl73xxf5\xq1), (v(xj1\xl73x xf5\xq1)) - (v(0)), i(vdxj\xl73xxf5\xq1), tj\xl73xxf5\xq1), -1000000000, 1000000000)}
[Error] Test XSpice Error: no such function ipc\xl73xxf5\xq1
[Error] Test XSpice Error parsing expression.

This is where my geak programming collegue came to help me. He then realized that the compiler in Altium requires that functions be declared before being used. After going around and trying to fix the order in which each function was declared, we reach a point where the simulation could start, but then obtain NAN from calculating the following line:

Class Document Source Message Time Date No.

[Error] Test XSpice Error: NAN, NAN out of range for / in (- (((wb\xdio\xq1) * (wb\xdio\xq1)) * (((((un\xdio\xq1) + (up\xdio\xq1)) * (if (z, 1, 0))) * (1E-6)) * ((((t) + (t0\xdio\xq1)) / (300)) ^ (-1.5))))) / (((((un\xdio\xq1) * (qn\xdio\xq1)) * ((((t) + (t0\xdio\xq1)) / (300)) ^ (-1.5))) + (((((un\xdio\xq1) + (up\xdio\xq1)) * (max (z, 0))) * (1E-6)) * ((((t) + (t0\xdio\xq1)) / (300)) ^ (-1.5)))) ^ (2))

Then, if I look at where that error comes from, it's from this line:

.FUNC Rd(Z,T) {wb*wb/(un*QN*(((T + t0)/300)**-1.5) + (un + up)*MAX(Z,0)*1e-6*(((T
+ + t0)/300)**-1.5))}

Any thoughts on what we should do?

Thank you for your help
0 Likes
1 Reply
forix
Employee
Employee
25 replies posted 10 replies posted 5 replies posted
You probably has faced a problem regarding recursion used in our model for the named devices.

The models for IGBT and diodes has been developed using the simulator SIMETRIX. The advantages are the higher speed and better stability compared to PSPICE.

Regrettably some parts of our model construction, which are working recursive, do not work with LTSPICE, Altium or ORCAD CAPTURE Spice which is caused by their solver. Since our models are reflecting the device physics we cannot do the model without the recursive functions.

Hope this helps.

0 Likes