Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

CO₂ sensor

User22572
Level 1
5 sign-ins First reply posted First question asked
Level 1
Good morning,

While testing the PASCO2 evaluation kit I have encountered the following error.

5337.attach



This error occurs randomly and stops the datalogging.
This issue seems to be getting worse by the day.
This makes it very difficult to asses the stability of the sensor.

The datalogging is done on a Windows 10 PC, the evaluation kit is connected with the USB cable provided.

It would be helpful if this error could have a timeout, so the software can try to connect automatically.


Kind regards,

Martin
0 Likes
1 Solution
GeorgeT
Moderator
Moderator First like given 100 sign-ins 10 solutions authored
Moderator

Hi @User22572

A possible reason for the IFX_ERROR_COMMUNICATION_ERROR is when the connection between mini board and mother board is disturbed while testing.

So please make sure that the boards are connected properly before testing and not getting disturbed while testing.

Please let us know if this solves your problem.

Best regards

George

View solution in original post

0 Likes
5 Replies
AjayB_76
Moderator
Moderator 100 sign-ins 10 questions asked 5 questions asked
Moderator

Hi Martin, Can you please update the Fusion GUI to see. I understand there are some fixes done to improve stability of the tool .

Thanks. 

0 Likes
User22572
Level 1
5 sign-ins First reply posted First question asked
Level 1

Unfortunately the updated Fusion GUI did not solve the issue.

The issue seems to appear when the computer is in screensaver mode and you have to use Ctrl-AltDel to login to Windows.

This only happens on 2 computers, the third one works without any problems

0 Likes
GeorgeT
Moderator
Moderator First like given 100 sign-ins 10 solutions authored
Moderator

Hi @User22572

A possible reason for the IFX_ERROR_COMMUNICATION_ERROR is when the connection between mini board and mother board is disturbed while testing.

So please make sure that the boards are connected properly before testing and not getting disturbed while testing.

Please let us know if this solves your problem.

Best regards

George

0 Likes
User22572
Level 1
5 sign-ins First reply posted First question asked
Level 1

Dear George,

I have updated the GUI software to the newest version. (3.1.3.202203091622)

This one produces data dumps, which I have attached.

This issue seems to be specific to only 2 computers.

 

I have tried the USB ports on the back (straight on the motherboard) and the front.

But the issue still persists.

It is not a big deal since I have a different computer which does not have this issue.

Maybe there is an issue with the virus scanner which aggressively holds the COM port?

 

Kind regards,

Martin

0 Likes
GeorgeT
Moderator
Moderator First like given 100 sign-ins 10 solutions authored
Moderator

Hi Martin,

Happy to know that the sensor is working properly in another computer.

From our understanding this issue seems to be associated with the particular computer as you mentioned .

Could you please share comparative information between the computers/measurement setup, the working and non-working ones?

1. Is the computer going to sleep mode in between the measurement?

2. Are you disconnecting or changing the  mini-evaluation board from the evaluation motherboard (as seen in the figure) while measurement is being done?

XENSIV PAS CO2 motherboard miniboard.png

3. Is the connection between mini-evaluation board and evaluation motherboard good and not getting disturbed while the measurement is being done?

Please let us know any key differences between the computers/setup other than the above mentioned.

Best regards,

George

0 Likes