Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

CAPSENSE™ & MagSense Forum Discussions

EmJay
Level 1
Level 1
First reply posted First like given First question asked

Is it possible to use CTANK-Pin to drive a shield elektrode ?

I use CSDV2 unit in a PSoC4000S (CY8C4045PVA-S412)  Device and want to use the Pin CTank (P4.3) to drive a shield elektrode. All other pins are used for sensing elektrodes and interfaces, so i tried to use Ctank-Pin to drive a shield
hatch on the PCB.
Capacitor Csh is not connected, and shielding methode is 'internal', using AmuxBuf and Switch-Resistors to generate shield signal. On other Pins, i can see a correct shield signal, but not for CTank (P4.3). 
What can i do to use P4.3 as shield drive?

I tried  to configure HSIOM-Port-Select Value 0x5 (CSD_SHIELD) for GPIO-Switching and 0x7 (AMUXB) for static Connection (to AmuxBusB). Both worked for other Pins, but not for Ctank-Pin.  Further i tried to use Register CSD_SW_DSI_SEL with value DSI_CSH_TANK = 0x1 (static connection). This is the reqired setting to use CTANK-Capacitor - but did not work.

Thank you.

0 Likes
2 Replies
Srivastav
Moderator
Moderator
Moderator
100 replies posted 25 likes received 100 sign-ins

Hi @EmJay,

As pointed by https://www.infineon.com/dgdl/Infineon-AN85951_PSoC_4_and_PSoC_6_MCU_CapSense_Design_Guide-Applicati... Table 37, PSoC 4S Series Csh_Tank is supported on P4[2], P4[3] and P4[1]. In case you are not using Csh_Tank, the pin can be used to drive the shield.  If after assigning the pin to shield you're not getting any build error, you can use that specific pin to drive shield.

Which Development Environment are you using? PSoC creator or ModusToolbox 3.0? Did you configure the Shield pin the CapSense configurator correctly? Can you share your project with us?

 

Thanks!
Kind Regards

Arpit Srivastav

0 Likes

Hi Srivastav,

i tried in PSoC Creator and Modus-Toolbox.

So created a sample application in PSoC Creator based on C8KIT-145 and share it (attached).  I used an Example named "CE210709_CapSense_Linear_Slider_and_Buttons" and modified it to show the problem.

On C8Kit-145 no Tank-Capacitor is mounted (C13), so internal shielding has to be used.

Modifications:

  • CSX Buttons removed in PSoC-Creator and Source-Code
  • Added Shield Electrode on P2.6 (Working correct)
  • Added Shield Electrode on P4.3 (CTank Pad , not working)
  • Removed C35 on C8KIT-145 (remove C35 from P4.3)

Attached you will find the project files.

Slider is working correct, Shield on P2.6 is working correct, Shield on P4.3 not working.

It would be really great to find a Solution for this !

Preview
 
 
 
 
 
 
 
 
0 Likes