Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

Bluetooth SDK Forum Discussions

netdown
Level 1
Level 1
First reply posted First question asked Welcome!

Hi,

I would like to enquire information whether BLE (BT 4) is enough for using the MeshClient app or BT 5 is required.

Furthermore, can I communicate with the network in desktop Java or I must use the C++ examples?

Thank you in advance.

0 Likes
1 Solution
Owen_Zhang123
Moderator
Moderator
Moderator
500 solutions authored 250 sign-ins 1000 replies posted

You can use a BLE-only device with version 4.2 or higher. 

As there are some lib files needed for the app, you need to use C++ for the development.

View solution in original post

0 Likes
4 Replies
Owen_Zhang123
Moderator
Moderator
Moderator
500 solutions authored 250 sign-ins 1000 replies posted
0 Likes
netdown
Level 1
Level 1
First reply posted First question asked Welcome!

I have checked the guide already, but it does not tell the required BT hardware version. Neither it has any info about desktop Java support.

0 Likes
netdown
Level 1
Level 1
First reply posted First question asked Welcome!

To clarify a bit more: can a BLE-only device (which only implements GATT bearer) act as a provisioner through a proxy node?

0 Likes
Owen_Zhang123
Moderator
Moderator
Moderator
500 solutions authored 250 sign-ins 1000 replies posted

You can use a BLE-only device with version 4.2 or higher. 

As there are some lib files needed for the app, you need to use C++ for the development.

0 Likes