Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

Bluetooth SDK Forum Discussions

AcSp_4798551
Level 3
25 sign-ins 10 replies posted 10 questions asked
Level 3

After some time not working with the ModusTool box I am not able to transfer a new build  to my board anymore. Say, I am always getting an error message like: "The file does not exist for the external tool named <project name> Program."

I found out that on my existing project the BUILD files are automatically named "EmptyWicedBluetooth..." now and I do not find any preferences to change that.

To verify the problem I created a new (empty BT) application project on target CYBT-413055-EVAL. Build the program and tried to upload to the board: the result was the same:  "The file does not exist for the external tool named <project name> Program."

What is my mistake ?

Achim

0 Likes
1 Solution
AcSp_4798551
Level 3
25 sign-ins 10 replies posted 10 questions asked
Level 3

Dear Sirs,

 

finally I decided a different approach:

Step 1: Save the project in an archive.
Step 2: Delete Modus Toolbox 2.2 / 2.2.1
Step 3: Reinstall ModusToolbox 2.2 / 2.2.1
Step 4: Import project from archive
Step 5: Update Libraries

Problem solved - whatever the problem was....

Thanks for your trails to help.

 

View solution in original post

0 Likes
7 Replies
BragadeeshV
Moderator
Moderator First question asked 1000 replies posted 750 replies posted
Moderator

Hi @AcSp_4798551 ,

Did you try to rename your project anytime? Clean the project to delete any previously generated hex files and perform a new build. Also, click on Generate launches on Quick panel -> Launches section. This should generate the new launch configurations for the current project name.BragadeeshV_0-1615893872840.png

Can you please let us know if this fixes the issue at your end?

 

Regards,
Bragadeesh
0 Likes
AcSp_4798551
Level 3
25 sign-ins 10 replies posted 10 questions asked
Level 3

Dear Bragadeesh, 

thanks for the quick reply:

- I tried all of your suggestions already - no success

- the strange thing is, that also on the new plain project the build name is wrong ...

Regards

Achim

 

0 Likes
BragadeeshV
Moderator
Moderator First question asked 1000 replies posted 750 replies posted
Moderator

Hi @AcSp_4798551 ,

Can you share with us the screen shot of the error message? Please click Show more details so that we can see the complete error.

We have also seen this error occur if the path length of the project is too long. Can you create a new workspace (with short path length) and create a new project from the New Application Wizard?

The BUILD name comes from the Makefile variable APPNAME. Did you by any chance modify the APPNAME in the make file?

If the error is still reproducible with a new project created in new workspace, we request you to archive the entire workspace and share it with us here.

Regards,
Bragadeesh
0 Likes
AcSp_4798551
Level 3
25 sign-ins 10 replies posted 10 questions asked
Level 3

screenshot.jpg

0 Likes
AcSp_4798551
Level 3
25 sign-ins 10 replies posted 10 questions asked
Level 3
 
0 Likes
BragadeeshV
Moderator
Moderator First question asked 1000 replies posted 750 replies posted
Moderator

Hi @AcSp_4798551 ,

Thank you for sharing the files with us. 

Can you please let us know which version of Modustoolbox you  are using? The Launches name in the screenshot you shared and the Launches name in the archived project seems different. (ie) The launches name have Jlink or MiniProg4_Kitprog suffixed in Modustoolbox 2.2. From your screenshot it looks like you are using ModusToolbox 2.1. Can you download modustoolbox 2.2 from here? Please update to modustoolbox 2.2, create a new workspace and then create a new project. Let us know if the issue still exists.

Did you try to import an already existing example project that was created using an older version of Modustoolbox? If yes did you  Would it be possible for you to send us the PFSLocationAP2 project with us?

Can you also share with us a snap shot of your environment variable settings?

The BUILD name and the project file name need not be the same. The BUILD name comes from the MakeFile APPNAME parameter and the project name comes from the Name of the project that you give while creating the new project in the New Application Wizard.

 

Regards,
Bragadeesh
0 Likes
AcSp_4798551
Level 3
25 sign-ins 10 replies posted 10 questions asked
Level 3

Dear Sirs,

 

finally I decided a different approach:

Step 1: Save the project in an archive.
Step 2: Delete Modus Toolbox 2.2 / 2.2.1
Step 3: Reinstall ModusToolbox 2.2 / 2.2.1
Step 4: Import project from archive
Step 5: Update Libraries

Problem solved - whatever the problem was....

Thanks for your trails to help.

 

0 Likes