Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

Bluetooth SDK Forum Discussions

KeTa_1341526
Level 5
Level 5
10 solutions authored 5 solutions authored 100 replies posted

Hi,

I have a question about the frequency of SCL in I2C Master mode on CYBT-343026-01 (Chip: CYW20706)/CYBT-353027-02 (Chip: CYW20707).

I'm using Modus Tool Box 2.3/BT SDK 3.1.

Using the I2C API as in the community below, I confirmed the waveform on the evaluation board of each module.

https://community.cypress.com/t5/WICED-Studio-Bluetooth/CYBT-353027-EVAL-I2C-not-working-in-EVM/m-p/...

https://community.cypress.com/t5/WICED-Studio-Bluetooth/I-need-Help-I2C-create-sample-code-cybt34302...

 

- Setting

wiced_hal_i2c_init( WICED_I2C_SDA_I2S_DOUT_PCM_OUT_SCL_I2S_DIN_PCM_IN );

wiced_hal_i2c_set_speed( I2CM_SPEED_100KHZ );

 

As a result, the SCL frequency is 185KHz with the following I2C settings.

See waveform below (CH1: SCL, CH2: SDA)

scope_0i2c.png

 

It should be set to 100KHz from the above setting, but it is not set.

Why?

 

Also, I set "wiced_hal_i2c_set_speed" to something other than "I2CM_SPEED_100KHZ". (I2CM_SPEED_400KHZ or I2CM_SPEED_800KHZ or I2CM_SPEED_1000KHZ)

However, all settings are 185KHz.

 

I have tried CYBT-343026-EVAL and CYBT-353027-EVAL, but both have the same phenomenon.

 

Best regards,

0 Likes
1 Solution
DheerajPK_41
Moderator
Moderator
Moderator
750 replies posted 500 likes received 500 replies posted

Hi,

We have found some issues in the I2C and our dev team is fixing it.  The fix will be available in the next SDK release. 

But for now, I am attaching a workaround code here. Not that it is not the complete fix. Please use it and let us know if you find any issues.

Use I2C_20706_DIV=42 for 800kHz SCL, I2C_20706_DIV=104 for 400kHz SCL, etc.

Thanks,

-Dheeraj

View solution in original post

0 Likes
4 Replies
DheerajPK_41
Moderator
Moderator
Moderator
750 replies posted 500 likes received 500 replies posted

Hi,

It should be possible to set different SCL. I am not sure what is the actual issue here.

We would like to reproduce the issue at our side and collect more data. Are you using any standard application provided by us? Could you please share your relevant code with us ?

 

Thanks,

-Dheeraj

0 Likes

Hi,

 

It is the same Code as the following Community. (The Slave address has changed.)

https://community.cypress.com/t5/WICED-Studio-Bluetooth/I-need-Help-I2C-create-sample-code-cybt34302...

 

In addition, the settings are as follows.

-Setting

  wiced_hal_i2c_init (WICED_I2C_SDA_I2S_DOUT_PCM_OUT_SCL_I2S_DIN_PCM_IN);

  wiced_hal_i2c_set_speed (I2CM_SPEED_100KHZ);

 

0 Likes

Hi,

Could you reproduce this issue on your side?

Best regards,

0 Likes
DheerajPK_41
Moderator
Moderator
Moderator
750 replies posted 500 likes received 500 replies posted

Hi,

We have found some issues in the I2C and our dev team is fixing it.  The fix will be available in the next SDK release. 

But for now, I am attaching a workaround code here. Not that it is not the complete fix. Please use it and let us know if you find any issues.

Use I2C_20706_DIV=42 for 800kHz SCL, I2C_20706_DIV=104 for 400kHz SCL, etc.

Thanks,

-Dheeraj

0 Likes