cancel
Showing results for 
Search instead for 
Did you mean: 

AnyCloud SDK

skruglewicz
New Contributor II

I trying to connect to my my home router I follow the instructions on the GitHub readme.me

I'm getting the following error:

Function whd_wifi_join failed at line 1622 checkres = 33555456
Connection to Wi-Fi network failed with error code 0x2000400. Retrying in 5000 ms. Retries left: 119

my router is set to:Router Security as WPA2 Personal

The secrity type in the file configs/wifi_config.h is set as follows:

#define WIFI_SECURITY CY_WCM_SECURITY_WPA2_AES_PSK

here is the error in the terminal screen.

skruglewicz_0-1634596881438.png

 

Could anyone give me some insight into what could be wrong?

Any help will be appreciated

 

 

Getting an error connecting to the WIFI 

 

0 Likes
1 Solution
skruglewicz
New Contributor II

 

Hello

Your correct. problem solved . I'm connected to my router now.

#define WIFI_SSID "MY_WIFI_SSID"

"MY_WIFI_SSID" had 2 characters in the wrong case!

The security type default in the file configs/wifi_config.h is set correct and works .It was not the connection problem 

#define WIFI_SECURITY CY_WCM_SECURITY_WPA2_AES_PSK

 

Thanks for your help

Steve K

View solution in original post

0 Likes
2 Replies
Rakesh_BG
Moderator
Moderator

Hi @skruglewicz 

I tried Anycloud MQTT client example on CY8CPROTO-062-4343W Kit.
Able to connect to router with properly configured SSID and password.
Got error similar to your case when the SSID or password is wrong.
Please verify the credentials of the AP in wifi_config.h and try.

/*******************************************************************************
* Macros
********************************************************************************/
/* SSID of the Wi-Fi Access Point to which the MQTT client connects. */
#define WIFI_SSID "MY_WIFI_SSID"

/* Passkey of the above mentioned Wi-Fi SSID. */
#define WIFI_PASSWORD "MY_WIFI_PASSWORD"

If still problem persists try with other access point .
If still the problem doesn't gets solved we will look again.

skruglewicz
New Contributor II

 

Hello

Your correct. problem solved . I'm connected to my router now.

#define WIFI_SSID "MY_WIFI_SSID"

"MY_WIFI_SSID" had 2 characters in the wrong case!

The security type default in the file configs/wifi_config.h is set correct and works .It was not the connection problem 

#define WIFI_SECURITY CY_WCM_SECURITY_WPA2_AES_PSK

 

Thanks for your help

Steve K

View solution in original post

0 Likes