Announcements

Equip yourself to optimize AURIX™ MCUs for Evs at the EV Webinar. Click here to register.

Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

AURIX™ Forum Discussions

MaxMax
Level 1
Level 1
First solution authored First reply posted First question asked

Hi,

I am new to developing with AURIX MCUs and tried to build a small application that reads data from a SPI Slave and Communicates to a PC via Ethernet. I've managed to get the examples for SPI over ASCLIN and the Ethernet example based on LwIP running fine.

Now I've ported the example into a new application with Core 0 handeling the SPI via ASCLIN2 and the Ethernet Echo example running on Core 2. For SPI Baudrates above 8.4Mbit/s this works perfectly fine, however for slower Baudrates the Ethernet is not responding and the LED on the Connector stays off. It seems like the instruction txData->U = *data++; of the Methode IfxAsclin_write8 causes this behaviour.

Does anyone has a Idea what could cause this? From my limited understanding of the Architecture, the use of the SPB should be the only intersection between Core 0 running SPI and Core 2 managing the GETH and using the debugger shows that the arbiter should use a round robin scheme to manage transfers.

Thanks for your help!

Max

0 Likes
1 Solution
MaxMax
Level 1
Level 1
First solution authored First reply posted First question asked

Problem Solved! P33.7 was designated as SCLK and is connected to the power down pin of the Ethernet Transceiver on the Lite Kit. A more clear hint about pin incompatibilitys in the used manual would be appriciated. 

View solution in original post

0 Likes
1 Reply
MaxMax
Level 1
Level 1
First solution authored First reply posted First question asked

Problem Solved! P33.7 was designated as SCLK and is connected to the power down pin of the Ethernet Transceiver on the Lite Kit. A more clear hint about pin incompatibilitys in the used manual would be appriciated. 

0 Likes