Announcements

Help us improve the Power & Sensing Selection Guide. Share feedback

Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

cross mob
User20310
Level 1
Level 1
First like received
Hello,
I'm working with the EVAL TC397 Hardware and I'm having a problem related to the reset for watchdog. when I connect the device with the debugger and flash my code, it works . means Wdg driver getting called. Rest will not work because Debugger will hold reset pin.
But when i remove debugger the power off or pressing the reset button, Then Reset LED glow(means reset happening). and nothing will work.
1.How to work with debugger mode?How to enable wdg in debugger mode?how to active watchdog in debugger? so that i can debug issue
2.What could be the reason for reset?


Thanks and Regards
sachin
0 Likes
3 Replies
MoD
Employee
Employee
10 likes given 50 likes received 500 replies posted
Make sure that the UCB_BMHD0 is programmed correctly with your used start address. Your code contains a valid BMHD?
Which debugger you use?
0 Likes
User20310
Level 1
Level 1
First like received
Hi MoD,
yes, My BMHDO is program correct. because without this even in debugger also it will not work.Start address is important to start software. So i am sure about it.
i am using WinIdea-Isystem.
0 Likes
MoD
Employee
Employee
10 likes given 50 likes received 500 replies posted
I don't know how the isystem support the watchdogs during debugging, maybe there exist any configuration.
Per default are the watchdogs are suspended when OCDS enabled.
You can switch off this feature by writing 0x3000 to address 0xF000047C.
Then the watchdogs will be suspended only when the corresponding suspend signal is active (e.g. when the CPU is in halt state).
0 Likes