Unable to Program TC397XA

Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

cross mob
Deep18041
Level 1
Level 1
First like received First solution authored First reply posted

we are using SAK-TC397XA-256F300S BD Powered from TLF35584QVHS2.
1. When we connect the supply 12 V at input of the PMIC we see the outputs generated but all these supplies along with POR signals pulses after 600ms for 20ms low. Which we think it is something to do with INIT timer.
2. So, to bypass this, we Pulled the MPS pin of TLF35584QVHS2 to high 5V so that we can use the Microcontroller Programming support feature. And I can see the Supplies and the POR is stable and Not Pulsing now.
However, when we try to flash the controller using DAP interface (Mini wiggler) with MPS held high (5V). We still see the programming failed. Attaching the logs here…

Below is the error message when MPS is pulled low:

Aurix Flasher 2.5.3.0, built on 3/17/2022 6:42:47 PM
Connected to device... [TRICORE] DAS JDS miniWiggler V3.1
::Loading HEX file ..........
:⚠️ The given program file is trying to write on reserved memory addresses, which will be skipped.
Overall time: 770 ms
AurixFlasher Exit Status: Fail
Flashing failed
Error message when MPS is pulled high:
Aurix Flasher 2.5.3.0, built on 3/17/2022 6:42:47 PM
Connected to device... [TRICORE] DAS JDS miniWiggler V3.1
::Loading HEX file ..........
:⚠️ The given program file is trying to write on reserved memory addresses, which will be skipped.
::Erasing Flash memory .......... (Pass)
::Programming Flash memory .......... (Pass)
AurixFlasher - DAS::Error: Device reset could not be performed.
Overall time: 3168 ms
AurixFlasher Exit Status: Fail
Flashing failed
The same code works on EVM KIT_A2G_TC397_3V3_TFT. let me know if we are missing something.

0 Likes
1 Solution
Deep18041
Level 1
Level 1
First like received First solution authored First reply posted

Hi @Nambi , Thanks for replying. The problem is resolved now. User Configurations were missing initially which we corrected and it got working. 

View solution in original post

2 Replies
Nambi
Moderator
Moderator
Moderator
50 likes received 5 likes given 100 solutions authored

Hi,

"AurixFlasher - DAS::Error: Device reset could not be performed."
Could you check the state of the PORST pin during this sequence? 

Best Regards.

0 Likes
Deep18041
Level 1
Level 1
First like received First solution authored First reply posted

Hi @Nambi , Thanks for replying. The problem is resolved now. User Configurations were missing initially which we corrected and it got working.