Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

cross mob
Not applicable
Hello together,

I would like to ask witch toolchain you are using working with the Erika OS.

I tried to use the Hightec GCC and the TASKING Compiler, but i getz stuck with a compilation error "multiple target patterns. Stop."

Host Platform is Win10. Is there a free and working compiler for Erika OS?

Thanks for your help
3 Replies
Not applicable
Hello Rico,

I have used both the compiler you stated, can you specify in which file you are getting this error?
Not applicable

I am using Hightec GCC on Windows 10 with Erika OS as well.

The version of the whole Hightec free entry toolchain is v4.9.1.0-infineon-1.1. You can get it at their website. I am also using Cygwin.

At first, it was a nightmare setting it up, and building it without errors, but after a few weeks of making sure all relevant paths are set to the tricore-gcc compiler, and clearing other difficulties with Erika, it ran perfectly.
Not applicable
Thanks for the answers.

As it is possible it started again from Scratch.

Created a new RT Druid Project, selected an example, Multicore Event Demo from the Tricore Example Folder.

I did NOT specify the compiler path since i think the problem is not a compiler problem.

I also tried with a compiler path specified but the error/log is the same as before.

Following console log appeared:

15:30:03 **** Build of configuration Default for project Test ****
"C:\\Users\\rico\\erikaos\\Test\\Debug\\make_launcher.bat" all
C:\cygwin\bin\bash found!
0 [main] bash 5748 find_fast_cwd: WARNING: Couldn't compute FAST_CWD pointer. Please report this problem to
the public mailing list cygwin@cygwin.com
Using erika files in /cygdrive/c/eclipse/plugins/COMEUE~4.201/ee_files
make -C master TARGET_NAME=myProject_master CPU_NUMID=0 GLOBAL_LINKSCRIPT=../shared_sym.lsl all
cygwin warning:
MS-DOS style path detected: \\Users\\rico\\erikaos\\Test
Preferred POSIX equivalent is: //Users//rico//erikaos//Test
CYGWIN environment variable option "nodosfilewarning" turns off this warning.
Consult the user's guide for more details about POSIX paths:
make[1]: Entering directory `/cygdrive/c/Users/rico/erikaos/Test/Debug/master'
/cygdrive/c/eclipse/plugins/COMEUE~4.201/ee_files/pkg/cfg/arch/rules_infineon_tc_generic.mk:228: *** multiple target patterns. Stop.
make[1]: Leaving directory `/cygdrive/c/Users/rico/erikaos/Test/Debug/master'
make: *** [CPU_MASTER-all] Error 2

What i am wundering about is the path names get changed in a strange way, but the files are found so it should be fine.

Hope you can help me a bit 🙂