TC39x GEth RX FIFO Overflow

Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

cross mob
Level 1
Level 1
Currently facing an issue where the GEth controller is dropping frames due to Rx FIFO overflow. I am trying to avoid this scenario as much as I can so that I can reduce the retransmission triggered by the software transport layer.

My use case has around 15 frames being received by the TC397 in quick succession (at around 100 microsecond intervals) . During this reception stage, 2 frames are dropped and the Received FIFO Overflow Count Register shows count value of 2.

I am using Infineon's AUTOSAR 4.2 MCAL drivers and have around 30 RxBuffers configured in it. My guess is that that the RX FIFO overflow happens at the MTL layer and the frames do not reach the RxBuffers in RAM. The 8KBytes of RXFIFO is filled up before it is freed.

The application clock frequency (f GETH) is 150MHz.

Is there any way that I can avoid the RX FIFO Overflow? Increasing the interval between the received frames is not an option as it is out of my scope of development.
0 Replies