TC387_MOTORCTR negative speed

Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

cross mob
lock attach
Attachments are accessible only for community members.
kelejichi111
Level 1
Level 1
First question asked First like given Welcome!

Hello, 

I am working with KIT_A2G_TC387_MOTORCTR board and motor manager by demo FOC control. I started from demo code but I have configured position control. 

when I set  target-speed through PmsmFoc_Interface_setMotorTargetSpeed() in debug model(the position control isn't work), the measSpeed will equal to  negative speed in speed control(detail as the attachment), the transfer process is right in code and the motor will run in speed = 6000. Since FOC software is based on demo code (I have made no changes in FOC, adc or pwm code) and it is implemented to control the motor with speeds from 0 to 6000 rpm, I would like to know what happen and whether this demo it's allow to execute the position control .

Thanks,

0 Likes
1 Solution
Jeremy_Z
Moderator
Moderator
Moderator
1000 replies posted 250 sign-ins 100 likes received

Hi @kelejichi111 
Regarding the question, I'd like to suggest you seek support from Infineon’s global network of partners to refine the motor solution to fit your design.
BR,
Jeremy

View solution in original post

0 Likes
1 Reply
Jeremy_Z
Moderator
Moderator
Moderator
1000 replies posted 250 sign-ins 100 likes received

Hi @kelejichi111 
Regarding the question, I'd like to suggest you seek support from Infineon’s global network of partners to refine the motor solution to fit your design.
BR,
Jeremy

0 Likes