Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

AURIX™ Forum Discussions

User20429
Level 1
Level 1
5 replies posted First reply posted First question asked
Hi,

I got a trouble with an TC275 chip when flashing new firmware by memtool with editing BMHD at address 0x80000000.
After that, I cannot connect to this device by memtool and get error message

4767.attach

Is there any way to rescue this device?

Many thanks,
0 Likes
4 Replies
Darren_Galpin
Employee
Employee
First solution authored First like received
I don't know enough about the tooling, but can you read any registers at all? Can you read the confirmation status of the BMHD UCBs, or the FSR register to see what the status of the flash is?
0 Likes
User20429
Level 1
Level 1
5 replies posted First reply posted First question asked
No. At the moment, I cannot connect to TC275 chip by memtool or winIDEA, so I cannot do anything.
0 Likes
MoD
Employee
Employee
250 sign-ins 25 likes received 50 solutions authored
Maybe the device is in a wrong boot mode. What is the state of the reset LED (ESR0)? They are always on or off? When you connect via Memtool the LED is on for a short time?
0 Likes
User20429
Level 1
Level 1
5 replies posted First reply posted First question asked
There are two green LEDs on miniWiggler. One is alway on when I connect miniWiggler to board by DAP port. One is on short time when I press connect on memtool.

Additional, I check and found that reset pin of chip PORST is always at low level (already pullup)
0 Likes