Announcements

Help us improve the Power & Sensing Selection Guide. Share feedback

Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

cross mob
User20130
Level 1
Level 1
Greetings Community,

I'm having issues getting official TC267_TFT App Kit Code to compile ("AURIX TC267x TFT Application Kit Firmware") and hoped someone could help.
(This is my entry into AURIX Development)

I'm using HighTec Free Entry Toolchain (incl IDE) and tried the following:

1) Configure project to accept HighTech Toolchain

Take this official project, import into HighTech IDE
Adapt CfgCompiler_Gnuc.mk
Add relevant environment variables (BINUTILS_PATH and PATH)
-> Compilation fails after a while with following errors:
[HTML]make all
FIND: Parameterformat falsch
Now Build started !!!
make[1]: Entering directory 'AppKitOrig'
Building output 2_Out/Tricore_Gnuc/AppKitOrig_Tricore.elf
c:/program files/hightech/toolchains/tricore/v4.9.3.0-infineon-1.0/bin/../lib/gcc/tricore/4.9.4/../../../../tricore/bin/ld.exe: error: invalid core architecture 'aurix' for option --mcpu=
make[1]: Leaving directory 'AppKitOrig'
collect2.exe: error: ld returned 1 exit status
make[1]: *** [1_ToolEnv/0_Build/9_Make/0_Src.mk:68: 2_Out/Tricore_Gnuc/AppKitOrig_Tricore.elf] Error 1
make: *** [Makefile:15: build] Error 2[/HTML]

2) Feed Project to AURIX IDE (Apply Steps of Attempt 1)

Same Result as 1)

3) Create new Project based on BIFACES BaseFramework_TC26xB and integrating official App Kit Code

This failed for me already. Will update this post after next attempt with results.
BIFACES Baseframework and Application Kit are structurally relatively different, so I'm not sure this approach is intended.

Update 1:
This time I used latest TC26B BIFACES Baseframework (Having an outdated framework available for download that contains stuff like BaseFramework_TC23xA and having an up to date one with stuff like BaseFramework_TC26B is very confusing!)

a) removed Source Code from TC26B
b) added TFT application sources (0_AppSW, 1_SrvSW, 2_CDrv, 4_McHal)
c) Added relevant environment variables (BINUTILS_PATH and PATH)
d) changed almost every source to no longer cause compile errors due to issues with includes (relative includes -> general includes e. g. "std/compiler.h" -> "compiler.h")

Now I'm getting errors like this (all within file IfxCpu_Intrinsics.h)
[HTML]"0_Src/4_McHal/Tricore/Cpu/Std/IfxCpu_Intrinsics.h:67:36: error: 'asm' undeclared (first use in this function)"[/HTML]

Maybe I have to add additional iLLD stuff?
0 Likes
1 Reply
alvimutmex234
Level 1
Level 1
First reply posted Welcome!
  1. Set Up Development Environment: Ensure you have the necessary tools installed, including compilers, IDEs, and SDKs.
  2. Download Firmware Source Code: Obtain the source code for the TC267 TFT AppKit firmware from the appropriate source repository or download link.
  3. Review Documentation: Familiarize yourself with the documentation accompanying the firmware source code, including any build instructions or dependencies.
  4. Install Required Dependencies: Install any necessary libraries, packages, or dependencies specified in the documentation to ensure a successful compilation process.
  5. Configure Build Environment: Adjust any configuration settings or parameters as needed to customize the build for your specific requirements.
  6. Set Compiler Options: Configure compiler options such as optimization level, target architecture, and debugging settings to optimize the build process.
  7. Resolve Dependencies: Ensure that all required libraries and dependencies are correctly installed and accessible by the compiler during the build process.
  8. Compile Source Code: Use the appropriate build command or script provided in the documentation to compile the firmware source code.
  9. Monitor Compilation Output: Monitor the compilation process for any errors, warnings, or other messages that may indicate issues with the build.
  10. Debug and Troubleshoot: Debug any compilation errors or issues encountered during the build process by analyzing compiler output and referring to documentation or online resources for troubleshooting guidance.
  11. Test Compiled Firmware: Once the compilation process completes successfully, test the compiled firmware to verify functionality and ensure that it meets the desired requirements.
  12. Document and Share Insights: Document the compilation process, including any challenges faced and solutions implemented, to aid future reference. Consider sharing your insights and experience with the Strands Nyt Unlimited community to contribute to collective knowledge sharing and collaboration.
 
 
 
 
 
 
0 Likes