Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

AURIX™ Forum Discussions

Jamber
Level 3
50 sign-ins First like received 25 sign-ins
Level 3

Hi, 

As is shown in the pic, after 1.3 supply on about 130us, the OSC is starting up, but then the wave is decreased and off, and until now the ESR0 is not released yet.

上电晶振波形.png

The software is stopped on the start-up code, and clock is not initialized.

2022-07-18_150418.png

 

And another question is the default value of OSCCON is not matched on the UserManual, PROCONDF is 0x00000000 in UCB:

2022-07-18_153658.png

Could you tell me why OSC start-up before software initialized it and then get turn-off?

Best Regards

Jamber

 

 

 

0 Likes
1 Solution
dw
Moderator
Moderator 50 likes received 250 sign-ins 100 solutions authored
Moderator

Hi Jamber,

dw_0-1659502601146.png

 

From the 0x0258, HYSEN=1b(Hysteresis is enabled),MODE=10b(Ext Input Clk mode and OSC power-saving mode),GAINSEL=11b(Maximum gain configuration)

About OSCCON Reset value = 0x0X1X, I think it depends on the status of OSC mode and debugging mode.

 

dw

View solution in original post

0 Likes
9 Replies
dw
Moderator
Moderator 50 likes received 250 sign-ins 100 solutions authored
Moderator

Hi Jamber,

Could you please explain a bit?

Do you use Triboard or own customized board? What hardware or software changed from the default settings?

 

dw

0 Likes
Jamber
Level 3
50 sign-ins First like received 25 sign-ins
Level 3

Hi, dw

I tried both customized board and Triboard KIT_A2G_TC387_3V3_TFT, which is a new board with default program,  and the issue is similar for both board.

Our FAE said it's normal according to Errata CCU_TC.H012, but don't know why the default value of SCU_OSCCON mismatch with UM.

Best Regards

Jamber

0 Likes
dw
Moderator
Moderator 50 likes received 250 sign-ins 100 solutions authored
Moderator

Thanks for infomation Jamber. 

For default Triboard, what software changed to make the OSC disappear?

Errata CCU_TC.H012:

 

configuration of the oscillator is always required before an external crystal / ceramic resonator can be used as clock source

 

Below description said there has no impact:

 

If VEXT is present then the oscillator could start oscillating(crystal/resonator connected). As soon as Cold PORST of AURIX™ is
released, the oscillator is set to External Input Mode and the oscillation decays. This characteristic behavior has no impact on the oscillator startup
as initiated by software.

 

 

dw

 

0 Likes
Jamber
Level 3
50 sign-ins First like received 25 sign-ins
Level 3

Hi, dw

The newTriboard is with default program, hasn't been programmed by us.

I think the Errata means after cold power-on the OSC is start-up automatically, and after POSRT released, the OSC will be decayed. After software initiated, the OSC will be started up again and formally.

Best Regards

Jamber

0 Likes
dw
Moderator
Moderator 50 likes received 250 sign-ins 100 solutions authored
Moderator

Hi Jamber,

For Reset Value of OSCCON, the value could be changed in IfxScuCcu_init() which is called from IfxCpu_CStart0.c

dw

0 Likes
Jamber
Level 3
50 sign-ins First like received 25 sign-ins
Level 3

Hi, dw

Thank you for your reply, but I still don't understand about the reset Value of OSCCON.

I set a while(1) before any configuration code executed, after cold reset and warm reset, the reset value is still 0x00000258.

2022-07-28_155233.png

Best Regards

Jamber

 

0 Likes
dw
Moderator
Moderator 50 likes received 250 sign-ins 100 solutions authored
Moderator

Hi Jamber,

In my project, there is a function called __StartUpSoftware().

And, if trace further, there is a Firmware to handle registers early.

dw

0 Likes
Jamber
Level 3
50 sign-ins First like received 25 sign-ins
Level 3

Hi, dw

Thank you for your patience. 

I think the Firmware handling OSCCON register by CAN BSL mode, shown in usermanual:

Jamber_0-1659007553835.png

But firstly, this mode is not entered and it's start from internal flash:

2022-07-28_193042.png

Secondly, OSCCFG is not set in UCB, so this option is disabled:

2022-07-28_194231.png

So I am still confused with the reset value of OSCCON register and looking for your further explanation.

Best Regards

Jamber

0 Likes
dw
Moderator
Moderator 50 likes received 250 sign-ins 100 solutions authored
Moderator

Hi Jamber,

dw_0-1659502601146.png

 

From the 0x0258, HYSEN=1b(Hysteresis is enabled),MODE=10b(Ext Input Clk mode and OSC power-saving mode),GAINSEL=11b(Maximum gain configuration)

About OSCCON Reset value = 0x0X1X, I think it depends on the status of OSC mode and debugging mode.

 

dw

0 Likes