Announcements

Equip yourself to optimize AURIX™ MCUs for Evs at the EV Webinar. Click here to register.

Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

AURIX™ Forum Discussions

hanumanagowda
Level 1
Level 1
First reply posted First like given First question asked

Hi,

I am working with TC399x AURIX MCU.

I2C Channel 1 is configured in Standard Mode and acting as Master.

I am using Asynchronous mode to read and write.

here are the steps,

1.  AsyncWrite with device address (Data Transfer and Protocol Interrupt is hit) and the controller is changed to read mode

2. AsyncRead with device address (Data Transfer interrupt hit) and But the controller doesn't seem to acknowledge the received data. because of this, the MCU protocol interrupt is not hit.

The above is observed only during debugging with breakpoints.

however, if I don't set breakpoint, there is no issue as AsyncWrite and AsyncRead is working fine.

 

Could you please help me with this?

 

Thanks and Regards,

Hanumanagowda M S

hanumana.gowda@veoneer.com

+91-9902768459

 

 

   

0 Likes
1 Solution
Nambi
Moderator
Moderator
Moderator
First like given 25 likes received 50 solutions authored

Hi,

Since the driver works as expected without the influence of the debugger, I do not see any issue here.

Could you confirm if you are using an ILLD- or MCAL-based driver?

Best Regards.

View solution in original post

1 Reply
Nambi
Moderator
Moderator
Moderator
First like given 25 likes received 50 solutions authored

Hi,

Since the driver works as expected without the influence of the debugger, I do not see any issue here.

Could you confirm if you are using an ILLD- or MCAL-based driver?

Best Regards.