Announcements

Help us improve the Power & Sensing Selection Guide. Share feedback

Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

cross mob
lock attach
Attachments are accessible only for community members.
avatar
Level 3
Level 3
First like received 10 replies posted 25 sign-ins

Dear all,

 

How to set output format to binary in BIFACE?

The currently shows *.elf and *.hex under the directory "2_Out\Tricore_Gnuc" (see output_file_format.png)

0 Likes
1 Solution
Prudhvi_E
Moderator
Moderator
Moderator
250 replies posted 100 solutions authored 25 likes received

Hello,

You can use the following option that works with Hightec compiler:

tricore-objcopy [options] <infile> <outfile>

Please find the description of the same from the users' guide below: 

tricore-objcopy can be used to generate a raw binary file by using an output target of "binary" (e.g., use -O binary)

Regards,

Prudhvi.

View solution in original post

0 Likes
2 Replies
Prudhvi_E
Moderator
Moderator
Moderator
250 replies posted 100 solutions authored 25 likes received

Hello,

You can use the following option that works with Hightec compiler:

tricore-objcopy [options] <infile> <outfile>

Please find the description of the same from the users' guide below: 

tricore-objcopy can be used to generate a raw binary file by using an output target of "binary" (e.g., use -O binary)

Regards,

Prudhvi.

0 Likes

Hi Prudhvi,

Use the command below, 

the converted binary file size is too big, about 756M bytes , is that make sense? thanks.

tricore-objcopy.exe -I ihex -O binary TC39B_Tc.hex TC39B_Tc.bin

 

hex_to_bin.png