Announcements

Help us improve the Power & Sensing Selection Guide. Share feedback

Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

cross mob
User14776
Level 1
Level 1
I purchased the program for the development board, and added the c file and the H file into the FrameWork,but can't compile .With the Tasking also I can't compile it.
How do I need to build a project to compile this program?
Thanks!
0 Likes
7 Replies
User13290
Level 5
Level 5
First like received First solution authored
Hi Wan,

Aurix_wff wrote:
I purchased the program for the development board, and added the c file and the H file into the FrameWork,but can't compile .With the Tasking also I can't compile it.
How do I need to build a project to compile this program?
Thanks!


Can you show us a snapshot of the error message? It may contain a hint as to what's happening.

Best regards,

Henk-Piet Glas
Principal Technical Specialist
0 Likes
User14776
Level 1
Level 1
HIGHTEC.henk-piet.glas wrote:
Hi Wan,



Can you show us a snapshot of the error message? It may contain a hint as to what's happening.

Best regards,

Henk-Piet Glas
Principal Technical Specialist


Thanks for your answer!
3232.attach
have set the path to the Tasking compiler and added the H file path in the project.
0 Likes
User13290
Level 5
Level 5
First like received First solution authored
Hi Wan,

Aurix_wff wrote:
Thanks for your answer!
3232.attach
have set the path to the Tasking compiler and added the H file path in the project.


Looking at the error message I think what you may be missing is the --include-file option. Within their IDE TASKING uses it to automatically pre-include SFR files. In your case, although you are using IDE, you are probably calling an external makefile that is part of the IFX framework. The IDE itself therefore has no control over it and you will have to find a way to add this option manually.

Calling external makefiles from IDE is sometimes denoted as non-managed makefiles. Preferably you'd like to have managed makefiles instead. These are automatically regenerated as soon as you change a compiler, assembler or linker setting. So the trick is to migrate a non-managed makefile project to a managed one instead. If you'd like to know how this is done, just take a peek into this documentation. Using a step-by-step approach it shows you how to jump all the hurdles.

Best regards,

Henk-Piet Glas
Principal Technical Specialist
0 Likes
User14776
Level 1
Level 1
HIGHTEC.henk-piet.glas wrote:
Hi Wan,



Looking at the error message I think what you may be missing is the --include-file option. Within their IDE TASKING uses it to automatically pre-include SFR files. In your case, although you are using IDE, you are probably calling an external makefile that is part of the IFX framework. The IDE itself therefore has no control over it and you will have to find a way to add this option manually.

Calling external makefiles from IDE is sometimes denoted as non-managed makefiles. Preferably you'd like to have managed makefiles instead. These are automatically regenerated as soon as you change a compiler, assembler or linker setting. So the trick is to migrate a non-managed makefile project to a managed one instead. If you'd like to know how this is done, just take a peek into this documentation. Using a step-by-step approach it shows you how to jump all the hurdles.

Best regards,

Henk-Piet Glas
Principal Technical Specialist


Thanks very much!
0 Likes
User13290
Level 5
Level 5
First like received First solution authored
Aurix_wff wrote:
Thanks very much!


My pleasure. Happy to help.

Best regards,

Henk-Piet Glas
Principal Technical Specialist
0 Likes
User14776
Level 1
Level 1
HIGHTEC.henk-piet.glas wrote:
My pleasure. Happy to help.

Best regards,

Henk-Piet Glas
Principal Technical Specialist


Thanks for your help!
First, I'm very sorry,my English is poor!
I follow your documentation, create a new project, add a Demo, and finally compile successfully.
I have learned a lot of knowledge.
3241.attach
0 Likes
User13290
Level 5
Level 5
First like received First solution authored
Hi Wan,

Aurix_wff wrote:
Thanks for your help!
First, I'm very sorry,my English is poor!
I follow your documentation, create a new project, add a Demo, and finally compile successfully.
I have learned a lot of knowledge.


That's brilliant! Happy to read you're making progress.

Best regards,

Henk-Piet Glas
Principal Technical Specialist
0 Likes