FreeRTOS integration into ADS (TC397)

Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

cross mob
Level 2
Level 2
25 sign-ins 5 questions asked 10 replies posted


I copied the FreeRTOS folder from the project [Automotive_Gateway_24V_ETH_LWIP_HTTPD] and past it into my work-space, 




Paths and Symbols configuration seems to be correct 



in Cpu0_Main.c, the 2 header file were included : 

#include "FreeRTOS.h"
#include "task.h"

When i want to use a function from the freeRTOS library like creating a Task or making a delay, the ADS does not recognise it 


Tried to clean the project and rebuild it, close the IDE... but none the solve the issue.

any though on that ?

Thank you.

1 Solution
2 Replies
lock attach
Attachments are accessible only for community members.
Level 2
Level 2
25 sign-ins 5 questions asked 10 replies posted

I have removed the complete FreeRTOS folder and import it again, the symbols are now resolved correctly.

i can create and run task but the vTaskDelay() is not working at all,no matter how much delay i put inside it, it does not wait it jump to next instruction immediatly.

tried with both variant vTaskDelay(1000/portTICK_PERIOD_MS); and vTaskDelay(pdMS_TO_TICKS(1000));

Also task switching is not working, it is stuck on Task1 and never jump to task2 maybe because Task1 runs without a valid waittime.

The PLL Clock is set to 300MHz. attached the configuration files for clock and FreeRTOS.

Thank you for the support.