FTD2XX.dll not found error while launching debugg with AURIX development studio

Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

cross mob
prasannabhat
Level 1
Level 1
5 sign-ins First reply posted First question asked

Hi Team,

I am following this geeting started document, to flash & debug example project for eval board Application Kit TC3X7 V2.0, with device SAK-TC397XX-256 F300S BD. SAK-TC397XX-256F300S BD 

I have installed AURIX development studio on windows 10.

Building the project works without any problems, but while launchuing the debugger , I get the below error "FTD2XX.dll not found ".

I get the same problem with both Tasking Debugger & WinIDEA debug configurations.

Additioanlly there is one more error when starting the tool "Check IFX Network" has encountered a problem. 

Any help in getting over this problem is appreciated.

Thank you,

Prasanna

Screenshot 2023-11-28 163821.jpgScreenshot 2023-11-28 163954.jpgScreenshot 2023-11-29 084326.jpg

 

 

0 Likes
4 Replies
Meet_T
Moderator
Moderator
Moderator
100 solutions authored 25 likes received 50 solutions authored

Hi @prasannabhat , As suggested in the error message have you tried reinstalling the ADS and see if that resolves the problem? Let me know if you still face the error even after reinstalling.

0 Likes
prasannabhat
Level 1
Level 1
5 sign-ins First reply posted First question asked

Hi @Meet_T 

I did try re-installing ADS.

I can see that FTD2XX.dll in installed as part of DAS_V8_0_5_SETUP (which is installed during the installation of ADS)

prasannabhat_0-1701415820984.png

I can find the missing dll here.

prasannabhat_1-1701415897942.png

Some  how ADS doesnt seem to find the path for the same.

I added this path to system variable Path , now the original issue is resolved.

But I am getting this new error.

prasannabhat_2-1701416125828.png

 

What could be going wrong herer ?

Something seems to be missing in the installation steps.

 

Thanks for the assistance.

Regards,

Prasanna

0 Likes
prasannabhat
Level 1
Level 1
5 sign-ins First reply posted First question asked

Hello Team,

Any leads on how can I proceed ? 

 

BR

Prasanna

0 Likes
Meet_T
Moderator
Moderator
Moderator
100 solutions authored 25 likes received 50 solutions authored

Hi @prasannabhat ,

 

In order to get a better understanding of what is happening additional information is needed:

 

Have the TASKING and winIDEA debuggers ever worked before on the machine used?


Have other Kits been used to verify the issue?

Can you check if the following is true?:
Building the project: Pass
Debugging using both TASKING and winIDEA (now) debugger fails


After the project is built successfully can it be flashed to the device (“Flash Active project” button in ADS)?


What happens if “MCD Basic Client” is launched (all cores of the connected device should be shown)?


Can you please uninstall DAS8.0.5 and reinstall it by using DAS_V8_0_5_SETUP.exe (which is stored in the folder of ADS installation – admin rights are needed)? Is there a change when trying to use the debuggers?

0 Likes