Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

AURIX™ Forum Discussions

MurbiesWalto
Level 1
First question asked Welcome!
Level 1

I am trying to enable ethernet communication on an Infineon Aurix Tricore, specifically TC29x. To this end I am using the Aurix SW_framework_tools and the ILLD supplied by Infineon on their Aurix

In the ILLD package and demo, they have a ethernet demo with loopback_mode enabled. This demo works fine on the board. I then wanted to send out a package to another machine to enable ethernet communication. I have tried fiddling around with settings, using wireshark with cross-over-cable, wireshark with switch, against windows and linux pc's. With no packages received

I am therefore unsure if the demo has the pinmap configured correctly, and/or if some settings I have missed should be changed. My question is therefore if anyone has enabled ethernet communication using the infineon tools, and can guide me?

Tools

I have chosen the HighTec toolchain using the debuger UDE, all are from the free tools available on Infineon.

Board

Infineon Aurix Tricore TC299 Starter Kit.

0 Likes
1 Reply
TBencher
Level 5
First like given 50 sign-ins 10 solutions authored
Level 5

Hi,

did you also check demo files for related Application Kit? You could download it from myICP and make it accessible in your project by just copying lwStack+Code into your project or just using an Application Kit for testing. Yes of course you should always check the pinmap due to different boards available.

Best regards,

TBencher

0 Likes