Announcements

Help us improve the Power & Sensing Selection Guide. Share feedback

Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

cross mob
gpsemeraro
Level 1
Level 1
First solution authored First reply posted First question asked

I'm trying to get up to speed with the ShieldBuddy board (TC275) using AURIX Development studio v 1.9.20 and I'm getting an error when I try to debug the default 'Hello World' application.

 

When I start the debugger I get this error dialog:

Error creating session
The debug instrument IO could not be initialized.
The GDI debug instrument provided the following error message.
Could not open Access HW

 

The complete console output is below.

 

Do I need debug hardware dongle?  I expected that it would use the USB that is connected between the board and the PC.  The "getting started" document describes the Arduino IDE and not the AURIX Development Studio.  Any help would be appreciated.


Thanks,

Greg

Using Debug Target Configuration:
Target: Generic Infineon AURIX Board
Selected CPU type: tc27xd
Register file: C:/Infineon/AURIX-Studio-1.9.20/plugins/com.tasking.ctc.debug.win32.x86_64_1.12.14.0/ctc/include/sfr/regtc27xd.xml
Communication: Universal Debug Access Server
Debug Instrument Module: gdi2mcdtc
Using Flash Configuration:
Monitor : C:\Infineon\AURIX-Studio-1.9.20\plugins\com.tasking.ctc.debug.win32.x86_64_1.12.14.0\ctc\etc\ftc27x.sre
Workspace address : 0x70000000
Number of devices : 5
Sector buffer size : 8192
Device 0:
Address : 0xA0000000,0x80000000
Vendor : Infineon
Chip : TC2_4560k
Subname : Program Flash 0
Width : 32
Size : 2097152
Number of chips : 1
Unused address lines : 0
Device 1:
Address : 0xA0200000,0x80200000
Vendor : Infineon
Chip : TC2_4560k
Subname : Program Flash 1
Width : 32
Size : 2097152
Number of chips : 1
Unused address lines : 0
Device 2:
Address : 0xAF000000
Vendor : Infineon
Chip : TC2_4560k
Subname : Data Flash Bank 0a
Width : 32
Size : 393216
Number of chips : 1
Unused address lines : 0
Device 3:
Address : 0xAF100000
Vendor : Infineon
Chip : TC2_4560k
Subname : Data Flash Bank 0b
Width : 32
Size : 16384
Number of chips : 1
Unused address lines : 0
Device 4:
Address : 0xAF110000
Vendor : Infineon
Chip : TC2_4560k
Subname : Data Flash Bank 1
Width : 32
Size : 65536
Number of chips : 1
Unused address lines : 0
Configuration: TC27xD
Starting Debugger...
The debug instrument IO could not be initialized.
The GDI debug instrument provided the following error message.
Could not open Access HW

0 Likes
1 Solution
The problem was that it was being held in reset. I had it plugged into a
USB hub on my laptop, when I plugged it in directly to the laptop it was no
longer held in reset and debugging works.

View solution in original post

0 Likes
2 Replies
Erick_G
Moderator
Moderator
Moderator
100 replies posted 10 likes received 100 sign-ins

Hi @gpsemeraro,

Are you able to see the device in MCD Basic Client? (this is installed with DAS when installing ADS)

As far as I know this board comes with an integrated debugger.

Best regards,

Erick

0 Likes
The problem was that it was being held in reset. I had it plugged into a
USB hub on my laptop, when I plugged it in directly to the laptop it was no
longer held in reset and debugging works.
0 Likes