CAN frames sent too slow

Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

cross mob
TC3XXNewbie
Level 1
Level 1
First question asked Welcome!

I have an issue I think its related to PLL but I am not yet sure.

When a PORST takes place or Cold Power on, frames are sent really slow with difference between each two frames too large.

however if I make a soft reset, the frames are sent with the expected time difference between each two frames.

and the behavior is consistent.

 

ECU powered down -> ECU powered up -> frames are sent with large difference consistently during runtime and are never adjusted to be sent quicker.

ECU powered down -> ECU powered up -> Soft Reset (App or System reset) -> CAN Frames are sent with correct difference

 

ECU powered down -> ECU powered up -> Soft Reset (App or System reset) -> CAN Frames are sent with correct difference -> PORST -> large difference is back again and stays consistently during the operation cycle.

 

0 Likes
3 Replies
TBencher
Level 6
Level 6
25 solutions authored 25 likes received 5 questions asked

Hi,

this is really unusual but also interesting issue. Please can you tell us which board you are using and can you also provide your source code with the initialization routines and maybe also the schematic?

Best,

TBencher

0 Likes
TBencher
Level 6
Level 6
25 solutions authored 25 likes received 5 questions asked

Hi again,

if those data tend to be confidential you could also drop it to info@tbench-solutions.com.
We'll have a look on that.

Best,

TBencher

0 Likes
Meet_T
Moderator
Moderator
Moderator
100 solutions authored 25 likes received 50 solutions authored

Hi @TC3XXNewbie ,

 

Can you provide us more details regarding the mechanism (like which timer?) that you are using for sending this CAN frames with your desired time difference and what are the configurations done for the same. From what you mentioned it seems that your software might be going through different paths of execution based on the type of last ECU reset, could you please check and let us know if that's the case? For further analysis we request you to provide us with some more information regarding your software flow and configurations.

 

Best Regards,

Meet.

0 Likes