CAN'T DETECT THE DEVICE WHEN USE MINIWIGGLER TO PROGRAM TC377TP

Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

cross mob
JASON1
Level 1
Level 1
5 sign-ins First like given First reply posted

as the title demostrated. failed in detect the device.how to solve this problem.any good advice?

 

0 Likes
4 Replies
Di_W
Moderator
Moderator
Moderator
1000 replies posted 250 solutions authored 100 likes received

If you encounter issues with the connection, you may consider trying another triboard or chip to troubleshoot the problem. By using an alternative device, you can determine whether the connection itself is the issue. If the connection works fine with the new triboard or chip, the problem may lie with the UCB of the original chip or triboard.

JASON1
Level 1
Level 1
5 sign-ins First like given First reply posted

thanks for your kindly reply. I have tried two customer boards.the failure is all the same. i'm so curious about that i choosen the tc37x(bsl/asc).but the error message indicates that failed to load default monitor Tricore.Asc.TC39x.UDAS. is the connection itself issue? meanwhile. I'm not sure which connector has to use to connect the target.DAP or JTAG? 

0 Likes
Di_W
Moderator
Moderator
Moderator
1000 replies posted 250 solutions authored 100 likes received

For a custom board, there is a need to determine whether the issue exists in all boards or only for a specific board. It is recommended to begin the analysis from a Triboard, which serves as a reference. The Triboard manual, containing the schematic, can provide valuable insights to analyze and identify the root cause of any issues encountered.https://www.infineon.com/dgdl/Infineon-ApplicationKitManual_TC3X7-UM-v02_00-EN.pdf?fileId=5546d46269...

The Triboard supports DAP and JTAG with miniWiggler debugger.

JASON1
Level 1
Level 1
5 sign-ins First like given First reply posted

hi dw

thanks for you reply.

the problem is fix now. there is another issue occured.the programmer only read function is working. the program and erase funciton both are not working. pasted the failure snapshot here. thanks

erase_log.JPG

0 Likes