Announcements

Help us improve the Power & Sensing Selection Guide. Share feedback

Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

cross mob
User16898
Level 4
Level 4
Hi,
I configured my can for 500kbit/s baud rate, and triggered it to send a frame once per 0.5s.
I'm receiving the frame via Pcan dongle.
The problem is that, periodically transmission is halted for 3 s.
It looks like following:
15 first frames are sent correctly --> 3s pause --> 10 frames are sent correctly -> 3s pause --> 10 frames are sent correctly --> 3s pause-> and so on.
Why such situation occurs ?


Pcan also throws BUSHEAVY warning.
Why this warning occurs while there are nearly no frames on bus?

My configuration is:

Two node in Can (Pcan and target)
no terminating resistors

f_source = f_PLL = 100 MHz
SCUCCUCON1.CANDIV : f_can = f_source

can bit timing registers:
    hwNode->BTR.U = 0;
hwNode->BTR.B.BRP = 9;
hwNode->BTR.B.SJW = 3;
hwNode->BTR.B.TSEG1 = 14;
hwNode->BTR.B.TSEG2 = 3;
hwNode->BTR.B.DIV8 = 0;


I work on Tc222L and TASKING IDE,
0 Likes
3 Replies
NeMa_4793301
Level 6
Level 6
10 likes received 10 solutions authored 5 solutions authored
Hi Lukas. Does this precisely match the settings on the PCAN side? The most common cause is a mismatch in TSEG1/TSEG2.

How long is the connection between PCAN and your target? You can probably get by without termination resistors for a meter or so, but it becomes more critical with a longer bus length.
0 Likes
User16898
Level 4
Level 4
Hi,
I checked bitratests and they are different on Aurix and Pcan.
My cable is about 2m long and I have terminating resistors, so I don't think it pose a problem.
0 Likes
BDhola
Level 1
Level 1
First question asked First reply posted 5 sign-ins

Hi can you share the source code of ypur program. I am working on same controller Tc222 with PCAN .

Thanks.

0 Likes