使用英飞凌UDE VISUAL PLATFORM遇到的问题

公告

大中华汽车电子生态圈社区并入开发者社区- 更多资讯点击此

Tip / 登入 to post questions, reply, level up, and achieve exciting badges. Know more

cross mob
xuxu
Level 3
Level 3
25 sign-ins 25 replies posted 5 questions asked

我想要使用下述这款软件对我的程序进行调试,使用的开发板是英飞凌官方的T234L triboard

xuxu_0-1679386362966.png

xuxu_1-1679386378051.jpeg

请问:

1 这款UDE可以通过英飞凌的DAP miniwiggle进行连接调试吗,如果可以的话,是否需要电脑上独立安装DAS才能运行(因为我只安装了ADS内部自带的DAS),以及需要如何对UDE的连接参数进行配置呢?

2 UDE可以运行AURIX DEVELOPMENT STUDIO生成的elf文件吗?

谢谢

 

0 点赞
1 解答
Jeremy_Z
Moderator
Moderator
Moderator
1000 replies posted 250 sign-ins 100 likes received

Hi @xuxu ,

有点奇怪,我先介绍一下我这边的测试环境,UDE是在HighTec安装时,一起安装的,一开始我是通过HighTec+UDE调试工程(你可以参考此链接),成功后,单独使用UDE(C:\Program Files\pls\UDE Starterkit 2021)也可以成功。

你不妨按照我的方式试一下。

BR,

Jeremy

 

在原帖中查看解决方案

13 回复数
Jeremy_Z
Moderator
Moderator
Moderator
1000 replies posted 250 sign-ins 100 likes received

Hi @xuxu ,

Thank you for your interest in Infineon Semiconductor products and for the opportunity to serve you.

1) 1 这款UDE可以通过英飞凌的DAP miniwiggle进行连接调试吗,如果可以的话,是否需要电脑上独立安装DAS才能运行(因为我只安装了ADS内部自带的DAS),以及需要如何对UDE的连接参数进行配置呢?

-- 只要安装了DAS就可以,方式不重要, 配置请参考此链接

2)UDE可以运行AURIX DEVELOPMENT STUDIO生成的elf文件吗?

-- 可以。

BR,

Jeremy

 

 

0 点赞
xuxu
Level 3
Level 3
25 sign-ins 25 replies posted 5 questions asked

hi @Jeremy_Z ,按照你的步骤我导入了lic

1 ,请问出现这一现象是导入失败了吗?该如何解决呢?

xuxu_0-1679454629702.png

 

2 ,并且在1的情况下,我按照你的步骤接着往下配置,出现了如下报错。请问是因为1导致的吗,如果不是的话该如何解决呢?

xuxu_1-1679454785586.png

期待收到回复!

 

 

 

0 点赞
Jeremy_Z
Moderator
Moderator
Moderator
1000 replies posted 250 sign-ins 100 likes received

Hi @xuxu ,

1) 请问出现这一现象是导入失败了吗?该如何解决呢?

-- 正常现象。

2)我这边是可以的(我用的是TriBoard TC397做的测试), 我建议你首先确认硬件是否被识别,其次再检查Target Configuration是否与硬件匹配。

2023-03-22_17h37_15.png

BR,

Jeremy

0 点赞
xuxu
Level 3
Level 3
25 sign-ins 25 replies posted 5 questions asked

hi @Jeremy_Z 

1 我的硬件是可以被识别的

xuxu_0-1679552229688.png

 

2,根据开发板上方的丝印,型号应该为Triboard TC2X4L

我在UDE当中选择

xuxu_2-1679552489825.png

并在Connect Target时选择Use Infineon DAS for starterkit。

 

出现报错:

xuxu_1-1679552429646.png

请问该怎么解决呢?谢谢!

0 点赞
Jeremy_Z
Moderator
Moderator
Moderator
1000 replies posted 250 sign-ins 100 likes received

Hi @xuxu ,

请试试这个Target Configuration。

xuxu_2-1679552489825.png

BR,

Jeremy

0 点赞
xuxu
Level 3
Level 3
25 sign-ins 25 replies posted 5 questions asked

hi @Jeremy_Zhou 

使用DAP配置也是报相同的错误,并且我的miniwiggler下载器使用的是JTAG下载接口。

根据报错的提示来看,请问会不会是lic的问题?

在线等待您的回复!

xuxu_0-1679556146502.png

 

0 点赞
Jeremy_Z
Moderator
Moderator
Moderator
1000 replies posted 250 sign-ins 100 likes received

Hi @xuxu ,

那你现在使用AURIX™ Development Studio可以正常debug上述开发板吗?

BR,

Jeremy

0 点赞
xuxu
Level 3
Level 3
25 sign-ins 25 replies posted 5 questions asked

hi @Jeremy_Z 

可以的

0 点赞
Jeremy_Z
Moderator
Moderator
Moderator
1000 replies posted 250 sign-ins 100 likes received

Hi @xuxu ,

问题解决了吗?

BR,

Jeremy

0 点赞
xuxu
Level 3
Level 3
25 sign-ins 25 replies posted 5 questions asked

hi,@Jeremy_Zhou

仍然连接不上,且公司电脑无法安装higtech,无法尝试您提供的方式。我想请问您一下

1,我使用的是英飞凌官方Triboard -TC2X4开发板,TC234芯片。那么我选择以下两种模式有区别吗?

xuxu_0-1679903754862.png

 

2,如果我选择上图第一种方式,并按照您提供的连接配置,会报错:

 

xuxu_1-1679904040853.png

 

 

2,如果我选择第二种方式,则会报错license无法识别有效ID号,在此基础上我更换了积分license,仍然报相同错误。

 

 

期待您的回答!

 

 

0 点赞
Jeremy_Z
Moderator
Moderator
Moderator
1000 replies posted 250 sign-ins 100 likes received

Hi @xuxu 

1) 我使用的是英飞凌官方Triboard -TC2X4开发板,TC234芯片。那么我选择以下两种模式有区别吗?

-- 应该是没有区别的。

你手上有其它Triboard吗,它们可以正常连接吗?

BR,

Jeremy

0 点赞
xuxu
Level 3
Level 3
25 sign-ins 25 replies posted 5 questions asked

hi @Jeremy_Z 

我手上没有别的triboard了😭

0 点赞
Jeremy_Z
Moderator
Moderator
Moderator
1000 replies posted 250 sign-ins 100 likes received

Hi @xuxu ,

有点奇怪,我先介绍一下我这边的测试环境,UDE是在HighTec安装时,一起安装的,一开始我是通过HighTec+UDE调试工程(你可以参考此链接),成功后,单独使用UDE(C:\Program Files\pls\UDE Starterkit 2021)也可以成功。

你不妨按照我的方式试一下。

BR,

Jeremy