Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

AURIX™ Development Studio Forum Discussions

User22362
Level 1
Level 1
First question asked Welcome!
Hi, i am using Aurix Development Studio,

i have a problem, recently i can not do a incremental compile successfully, every time when i changed something and tried to do an incremental buiding, the error came out:


19:48:37 **** Incremental Build of configuration Debug for project tricore_397_custom_bsw ****
make --output-sync -j12 all
mcal/tresos_conf/tricore397_custom/output/generated/src/Adc_PBcfg.d:3: *** target pattern contains no '%'. Stop.
"make --output-sync -j12 all" terminated with exit code 2. Build might be incomplete.

19:48:37 Build Failed. 1 errors, 0 warnings. (took 127ms)


so , now i have to right click, clean project, and then make again, which is time consuming.

Anyone knows how to fix this issue? Appreciated.


------aurix development studio about----
Version: 1.3.2
Build id: 20210219-1642
0 Likes
2 Replies
teoBits
Employee
Employee
100 replies posted 50 replies posted 25 replies posted
Hello,

please try to update the AURIX Development Studio to the latest version (1.5.0)
0 Likes
enrico_b
Employee
Employee
First like given 10 sign-ins 5 solutions authored
Hello,

this same issue happens also when the source files are external to the workspace. Are all source files physically contained in the project folder, and the project folder is located in the workspace? Was the project imported using the native Eclipse import function?

Regards,
Enrico
0 Likes