Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

cross mob
lock attach
Attachments are accessible only for community members.
User-6_6-
Employee
Employee
50 sign-ins 10 replies posted 5 replies posted

No issue when debug active project by Launching debug configuration: Blinky_LED_1_KIT_TC375_SB.
But facing error when trying to flash active project by Launching AURIXFlasher.

ADS Console message:
Aurix Flasher 2.5.3.2, built on 12/20/2022 5:58:37 PM
Connected to device... [TRICORE] DAS DAP over USB MiniWiggler
::Loading HEX file ..........
:‌‌ The given program file is trying to write on reserved memory addresses, which will be skipped.
Overall time: 646 ms
AurixFlasher Exit Status: Fail
Flashing failed

Command Prompt message:
Microsoft Windows [Version 10.0.19045.3086]
(c) Microsoft Corporation. All rights reserved.

C:\AURIX-Studio-1.9.4\plugins\com.infineon.aurix.tools_1.9.4\build_system\tools\AurixFlasher_v2.5.3.2>AurixFlasher.exe -hex C:\AURIX-v1.9.4-workspace\Blinky_LED_1_KIT_TC375_SB\Debug\Blinky_LED_1_KIT_TC375_SB.hex -log log.xml
Aurix Flasher 2.5.3.2, built on 12/20/2022 5:58:37 PM
das->open_port: DAS_ERROR_SERVER_LOCKED
DASWRAPPER::No ECF hardware found

::Generating the log file: log.xml .......... (Pass)
Overall time: 222 ms
AurixFlasher Exit Status: Fail

Attach "log.xml" file.
Attach "ADS Console [Debug OK]" file.

 

0 Likes
1 Solution
User-6_6-
Employee
Employee
50 sign-ins 10 replies posted 5 replies posted

Hi,

You may close this ticket.

Issue is related to HW. Changed pull-up resistor from 10 Kohm to 3.3Kohm on the pin PORST solve the issue.

View solution in original post

19 Replies
Jeremy_Z
Moderator
Moderator
Moderator
1000 replies posted 250 sign-ins 100 likes received

Hi @User-6_6- 
According to the statement, it can debug the board in the ADS, however, AurixFlasher fails to download the image file to the board, is my understanding right? If yes, in my opinion, it seems a bit weird, maybe you can restart the ADS IDE and reconnect the board, then give it a try again.
BR,
Jeremy

0 Likes
User-6_6-
Employee
Employee
50 sign-ins 10 replies posted 5 replies posted

Your understanding is correct. No issue with debug.

I first tried with ADS V1.9.0, but failed. Then upgrade to ADS V1.9.4, but still see the same issue.

Can you provide some info on the possible causes to this issue, and suggestions, pls.

0 Likes
Jeremy_Z
Moderator
Moderator
Moderator
1000 replies posted 250 sign-ins 100 likes received

Hi @User13836 ,

Can you share some suggestions about the weird phenomenon?

BR,

Jeremy

 

0 Likes
User13836
Level 6
Level 6
50 likes received 50 solutions authored 100 sign-ins

Do you face the problem with the Sield Buddy example project named Blinky_LED_1_KIT_TC375_SB only, or does it also show with other example projects or for a project created from scratch for the TC375 Shield Buddy hardware?

I do not have access to a TC375 Shield Buddy hardware to verify this. When I run a TC39xB application on a TC39xB TriBoard, this works without an error. But the flasher is also showing a diagnostic message:

 

Aurix Flasher 2.5.3.2, built on 20.12.2022 10:58:37
Connected to device... [TRICORE] DAS JDS TriBoard TC399 TH V2.01
::Loading HEX file ..........
:⚠️ The given program file is trying to write on reserved memory addresses, which will be skipped.
::Erasing Flash memory .......... (Pass)
::Programming Flash memory .......... (Pass)
Overall time: 2788 ms
AurixFlasher Exit Status: Pass
Flashing was successfull

Best regards,
Ulrich Kloidt

TASKING tools support

0 Likes
User-6_6-
Employee
Employee
50 sign-ins 10 replies posted 5 replies posted

I also tried with Blinky_LED_1_KIT_TC375_LK, and is facing the same issue.

It is a custom board with TC375TP AA-step, connected to PC via DAP miniWiggler V3.1.

The flasher is showing below diagnostic message:

Aurix Flasher 2.5.3.2, built on 12/20/2022 5:58:37 PM
Connected to device... [TRICORE] DAS JDS miniWiggler V3.1
::Loading HEX file ..........
:⚠️ The given program file is trying to write on reserved memory addresses, which will be skipped.
Overall time: 1284 ms
AurixFlasher Exit Status: Fail
Flashing failed

 

0 Likes
Jeremy_Z
Moderator
Moderator
Moderator
1000 replies posted 250 sign-ins 100 likes received

Hi @User-6_6- 
Does the issue also exist on multi custom boards? Further, do you have the TC375 infineon evaluation board on hand? If yes, does the board encounter the same issue?
BR,
Jeremy

0 Likes
User-6_6-
Employee
Employee
50 sign-ins 10 replies posted 5 replies posted

Hi,
Same issue on multi custom boards.
No issue with TC375 Lite Kit V2 board.

0 Likes
User-6_6-
Employee
Employee
50 sign-ins 10 replies posted 5 replies posted

Is there any differences in handling process internally when ADS uses AurixFlasher vs debug configuration?

0 Likes
Jeremy_Z
Moderator
Moderator
Moderator
1000 replies posted 250 sign-ins 100 likes received

Hi @User-6_6- 
I was wondering if you can share the schematic of your customized board.

@User13836 Can you share some comments about the above question?
BR,
Jeremy

0 Likes

Hi Jeremy,

 

Please find the schematic for the DAP connect in attached.

User6_6_2-1689062693846.png

 

 

0 Likes
Jeremy_Z
Moderator
Moderator
Moderator
1000 replies posted 250 sign-ins 100 likes received

Hi @User-6_6- ,

Please connect Reset of DAP connector to /PORST NOT /TRST.

BR,

Jeremy

0 Likes

Hi,

I could not see the connection (Reset of DAP connector to /TRST) you mentioned.

Could you tell me the specific pin?

FYI. this DAP connection is copied from ApplicationKitManual-TC3X7-V21.pdf 

0 Likes
Jeremy_Z
Moderator
Moderator
Moderator
1000 replies posted 250 sign-ins 100 likes received

Hi @User-6_6- 
After further checking, I think the DAP connector is right, and I have no idea about the weird issue now.
BR,
Jeremy

0 Likes
Jeremy_Z
Moderator
Moderator
Moderator
1000 replies posted 250 sign-ins 100 likes received

Hi @User-6_6- ,

How's going on?

BR,

Jeremy

0 Likes

Still not working.

Any information on how AurixFlasher in ADS works?

Does it need to verify certain data in order to work?

0 Likes
Jeremy_Z
Moderator
Moderator
Moderator
1000 replies posted 250 sign-ins 100 likes received

Hi @User-6_6-  ,
According to other customers' feedback, maybe you can try to update the ADS, then give it a try again.
BR,
Jeremy

0 Likes
Jeremy_Z
Moderator
Moderator
Moderator
1000 replies posted 250 sign-ins 100 likes received

Hi @User-6_6- ,

How're things going?

BR,

Jeremy

0 Likes

I have tried ADS v1.9.8. The issue remains  the same.

See error message:

AURIX Flasher Software Tool 1.0.8.0, built on 7/7/2023 10:18:22 pm
Connected to device... [TRICORE] DAS JDS miniWiggler V3.1
::Loading HEX file ..........
:⚠️ The given program file is trying to write on reserved memory addresses, which will be skipped.
Overall time: 1524 ms
AURIXFlasher Exit Status: Fail
Flashing failed

I checked the connection to board. It is OK.

User6_6_0-1690871197684.png

I observed below. Is this correct?

- AURIX-Studio-1.9.4 uses Aurix Flasher 2.5.3.2

- AURIX-Studio-1.9.8 uses AURIX Flasher Software Tool 1.0.8.0

0 Likes
User-6_6-
Employee
Employee
50 sign-ins 10 replies posted 5 replies posted

Hi,

You may close this ticket.

Issue is related to HW. Changed pull-up resistor from 10 Kohm to 3.3Kohm on the pin PORST solve the issue.