Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

AIROC™ Bluetooth Forum Discussions

carlosfinocchia
Level 1
Level 1
5 sign-ins First reply posted First like given

I am working with a CYBT-483056-EVAL board and trying to connect to a Bluetooth classic device.  I am using a serial terminal to send commands to the eval board via the USB port.  I am unable to connect to a device. I tried connecting the first time (To pair) and the second time (To connect) and I'm not successful. I get error 500 and then error 1600. I don't know what those mean or how to fix it.

##### FACTORY DEFAULT (I want to start clean)

/RFAC
@R,000B,/RFAC,0000
@E,0005,RFAC
@E,0040,BOOT,E=01000A1B,S=02072276,P=0100,H=E8,C=00,A=EE596D3A570C,T=01
@E,000E,ASC,S=03,R=01

##### QUERY BONDS (No bonds at this time)

/QB
@R,000E,/QB,0000,C=00

##### CONNECT USING SPP (Error 500 is "GAP error category" What does that means?)

/BTC,A=886B0F5114C7,P=00
@R,000A,/BTC,0000
@E,001F,BTCON,C=01,A=886B0F5114C7,B=00
@E,000F,PR,C=01,R=0000
@E,000E,ENC,C=01,S=01
@E,0020,BTCF,C=00,A=886B0F5114C7,R=EEEE
@E,001F,BTPDIS,C=00,P=00,H=0003,R=0000
@E,0012,BTDIS,C=01,R=0500

##### QUERY BONDS AGAIN (Now we can see a bond to the right device Address)

/QB
@R,000E,/QB,0000,C=01
@E,0020,B,C=00,A=886B0F5114C7,T=00,D=01

##### CONNECT AGAIN AS PER DATA SHEET (Again error 500?)

/BTC,A=886B0F5114C7,P=00
@R,000A,/BTC,0000
@E,001F,BTCON,C=01,A=886B0F5114C7,B=00
@E,000E,ENC,C=01,S=01
@E,0020,BTCF,C=00,A=886B0F5114C7,R=EEEE
@E,001F,BTPDIS,C=00,P=00,H=0001,R=0000
@E,0012,BTDIS,C=01,R=0500

##### TRY AGAIN TO CONNECT (Again error 500?)

/BTC,A=886B0F5114C7,P=00
@R,000A,/BTC,0000
@E,001F,BTCON,C=01,A=886B0F5114C7,B=00
@E,000E,ENC,C=01,S=01
@E,0020,BTCF,C=00,A=886B0F5114C7,R=EEEE
@E,001F,BTPDIS,C=00,P=00,H=0001,R=0000
@E,0012,BTDIS,C=01,R=0500

##### TRY AGAIN TO CONNECT (now the error is 1600 and there is nothing in documentation about this error)

/BTC,A=886B0F5114C7,P=00
@R,000A,/BTC,0000
@E,001F,BTCON,C=01,A=886B0F5114C7,B=00
@E,0012,BTDIS,C=01,R=1600

##### QUERY BONDS AGAIN

/QB
@R,000E,/QB,0000,C=01
@E,0020,B,C=00,A=886B0F5114C7,T=00,D=01

0 Likes
5 Replies
PratikshaV
Moderator
Moderator
Moderator
50 solutions authored 10 likes received 100 replies posted

Hi @carlosfinocchia ,

I hope you are referring this User guide and for error code you can refer page no 239.I will also test this at my end and get back to you soon on this.

 

Thanks & Regards

Pratiksha V

@PratikshaV Yes that is the same user guide I'm using as reference. Thank you, I have tried pretty much everything in my knowledge and I'm not able to stablish connection. 

0 Likes
carlosfinocchia
Level 1
Level 1
5 sign-ins First reply posted First like given

@PratikshaV Any luck testing this? We really need support on this.

0 Likes

Hi @carlosfinocchia 

Sorry for the delayed response..

Please make sure both the devices are disconnected before reconnecting once again. Also please can you share me the detailed logs. 

 

Thanks & Regards

Pratiksha V

0 Likes
carlosfinocchia
Level 1
Level 1
5 sign-ins First reply posted First like given

@PratikshaV Yes both devices are disconnected before reconnection, What do you mean by "Detailed logs"? What I shared is everything I get on the terminal. (minus the comments i made starting with the "#####")

0 Likes