Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

3D Hall (Magnetic sensor) Forum Discussions

rsiigod
Level 3
Level 3
25 replies posted 50 sign-ins First solution authored

Hi everyone
Good day~
When I connect the EVK, then a dialog pops up reminding me to update the firmware.

SAC_Ade_Chen_0-1647917609048.png

 

But the update failed, resulting in an inability to connect.
How could I rescue it?

SAC_Ade_Chen_1-1647918105003.png

 

0 Likes
1 Solution
PalY
Moderator
Moderator
Moderator
100 replies posted 25 solutions authored 10 likes received

Hi @rsiigod,

You can download the GUI for Angle sensors 2Go from the free downloads section on this page .

Hope this resolves this issue.

Thanks and regards,
Yashraj

View solution in original post

19 Replies
PalY
Moderator
Moderator
Moderator
100 replies posted 25 solutions authored 10 likes received

Hi @rsiigod,

Could you try fresh installation, and while installing, please ensure that the dependencies, Segger-J-Link V6.94c and .NET framework 4.7.1 is installed.

Regards,

Yashraj

0 Likes
rsiigod
Level 3
Level 3
25 replies posted 50 sign-ins First solution authored

Hi @PalY 

Good day~
I have some EVKs on hand, some updates succeeded and 2 pcs failed updates.
Should I not need to try a fresh install?

In addition, I asked a colleague to install another test, but it still couldn't connect.

Regards,
Ade

0 Likes
PalY
Moderator
Moderator
Moderator
100 replies posted 25 solutions authored 10 likes received

Hi @rsiigod ,

The firmware J-Link version that is shown in the image you shared, is J-Link V6.56b. But the current software installs J-Link V6.94c.

Seeing this version conflict I advised fresh installation. Maybe you could share the version of TLx-493D MS2Go that you are installing if the fresh installation does not work. 

This is the current version of software and firmware after installation.

Screenshot (361).png

Regards, 
Yashraj

0 Likes
rsiigod
Level 3
Level 3
25 replies posted 50 sign-ins First solution authored

Hi @PalY 
Good day~

My current version:

SAC_Ade_Chen_0-1648018430062.png

GUI for 3D magnetic sensor 2GO kits Download from Infineon website.
I have just reinstalled it and still can't connect successfully....

 

Regards, 
Ade

 

0 Likes
PalY
Moderator
Moderator
Moderator
100 replies posted 25 solutions authored 10 likes received

Hi @rsiigod,

You can try uninstalling the J-Link driver.

Connect the device EVK. Then go to "Device Manager"-> "Universal Serial Bus Controllers" -> "J-Link driver" -> "Driver" -> "Uninstall" and then press "OK".

Screenshot (364).png

Screenshot (365).png

After that try fresh installation.

Regards, 
Yashraj

0 Likes
rsiigod
Level 3
Level 3
25 replies posted 50 sign-ins First solution authored

Hi @PalY 

Good day~

I did try to clicked "Uninstall Device", uninstall "GUI for 3D magnetic sensor 2GO kits" and then restart my PC.
After that try fresh installation.

But it still fails to connect to this EVK, but other EVKs are ok.
I think it has nothing to do with the device driver.

My guess is that when the J-link firmware was updated failed, the bootload was damaged, so the J-link could not be connected to the computer normally.

How could I rewrite the firmware with an additional device? 
E.g SEGGER J-link?

SAC_Ade_Chen_1-1648082272027.jpeg

 

Regards, 
Ade

0 Likes
PalY
Moderator
Moderator
Moderator
100 replies posted 25 solutions authored 10 likes received

Hi @rsiigod,

Sorry for the trouble with the EVK.

I would like for you to try another method of installation.

Install Infineon Developer Center Tool,  using the link for your PC.
After installation you click on "Manage Tools", and search for "TLx493D Magnetic Sensor Evaluation App" and install this app with all the dependencies. After installation, the app will be visible under "My Tools" space.

Screenshot (366).png

Hope this method works for you.

Regards,
Yashraj

0 Likes
rsiigod
Level 3
Level 3
25 replies posted 50 sign-ins First solution authored

Hi @PalY 

Good day~
Still connect failed...
I am attaching the dynamic picture for your reference.

SAC_Ade_Chen_0-1648177769682.gif

Another successful connection:

SAC_Ade_Chen_2-1648178197586.gif

 

 

Regards, 
Ade

0 Likes
PalY
Moderator
Moderator
Moderator
100 replies posted 25 solutions authored 10 likes received

Hi @rsiigod , 

Could you please tell me the Evaluation Kit's details.
I am looking further into it, by recreating the problem on our end.

Thanks and regards,
Yashraj

0 Likes
rsiigod
Level 3
Level 3
25 replies posted 50 sign-ins First solution authored

Hi @PalY 

Good day~


Operating environment:
MacBook Pro 16' 2019
Parallels Desktop 17.1.1
Win10 ver. 2004
Evk:
1. Angle Sensor 2Go V1

SAC_Ade_Chen_0-1648428442903.png

 


2. XMC 2Go v1

SAC_Ade_Chen_1-1648428498174.png

 

 

Regards, 
Ade

0 Likes
PalY
Moderator
Moderator
Moderator
100 replies posted 25 solutions authored 10 likes received

Hi @rsiigod ,

The TLx493D MS2Go GUI supports only TLx493D sensors which are part of 3D Magnetic Sensors .

The Angle Sensor 2Go kit will work with its own GUI. If you could share me the name of the Angle Sensor onboard the kit, I could suggest you the right GUI.  

Regards,
Yashraj

0 Likes
rsiigod
Level 3
Level 3
25 replies posted 50 sign-ins First solution authored

Hi @PalY 

Good day~

The Angle Sensor 2Go kit: 

SAC_Ade_Chen_0-1648797412199.png

SAC_Ade_Chen_1-1648797446062.png

What GUI could I use to demo?

 

Regards, 
Ade

0 Likes
PalY
Moderator
Moderator
Moderator
100 replies posted 25 solutions authored 10 likes received

Hi @rsiigod ,

I can't read the sensors name from the picture, it is slightly cut off. It starts with "TLx50....", in the bottom of the first picture. 
Could you reply with that name for me to give the best answer.

In the mean time you could follow options given below to demo the angle sensors kit.

  1. You could also choose different tools from the following Angle Sensors Softwares & Tools according to the sensor.
  2. Also, if you have downloaded Infineon Developer Center, you could search for Angle Sensors in Manage Tools and install the TLE5x09D Dual Angle Sensor Eval. App. 

Thanks and regards,
Yashraj

0 Likes
rsiigod
Level 3
Level 3
25 replies posted 50 sign-ins First solution authored

Hi @PalY 

Sorry, It's TLx5012B-Exxxx.

Regards, 
Ade

0 Likes
PalY
Moderator
Moderator
Moderator
100 replies posted 25 solutions authored 10 likes received

Hi @rsiigod , 

You can download the Software for Evaluation Kit here https://www.infineon.com/dgdl/Infineon-AngleEvalKitSoftware5009%205011%205109%205012%205012B-SW-v01_... 

Thanks and regards,
Yashraj

0 Likes
rsiigod
Level 3
Level 3
25 replies posted 50 sign-ins First solution authored

Hi @PalY 

Good day~
Sorry for the late reply.

I'm Trying the GUI, but the device is not recognized.
It is well recognized when I use other GUIs.

SAC_Ade_Chen_0-1649727683434.png

I'm watching the Youtube too: https://www.youtube.com/watch?v=231i36xtkYE
He seems to be using a different version than mine.

 

0 Likes
PalY
Moderator
Moderator
Moderator
100 replies posted 25 solutions authored 10 likes received

Hi @rsiigod,

We are trying to simulate the same problem, and  I have forwarded your query to our internal team.

Thanks for your patience. 

Regards,
Yashraj 

0 Likes
PalY
Moderator
Moderator
Moderator
100 replies posted 25 solutions authored 10 likes received

Hi @rsiigod,

You can download the GUI for Angle sensors 2Go from the free downloads section on this page .

Hope this resolves this issue.

Thanks and regards,
Yashraj

rsiigod
Level 3
Level 3
25 replies posted 50 sign-ins First solution authored

Hi @PalY 

It finally works, thanks for your help.

 

Regards, 
Ade

0 Likes