iMotion Solution Designer 的設定精靈中出現問題:“錯誤:底層範圍的TESTBOARD_150PC_OUT ”

Tip / 登入 to post questions, reply, level up, and achieve exciting badges. Know more

cross mob
Translation_Bot
Community Manager
Community Manager
Community Manager

硬件和軟件:

  1. EVAL-M1-101TF
  2. EVAL-M1-IM535
  3. Windows 11 上的 iMotion 解決方案設計師

問題:

  1. 我已將 EVAL-M1-101TF 與 EVAL-M1-IM535 POWER_DRILL2GO TDA5235_868_5_BOARD連接
  2. 我還可以從 " 程序員 " 標籤中成功上傳固件
  3. 但是,當我嘗試在「設定精靈」標籤中設定參數時,即使使用預設的 EVAL-M1-101TF + EVAL-M1-IM535 配置和建議的WM_MOTOR_CONTROL_01 (USB WM_MOTOR_CONTROL_01 (iMotion2go)) 或任何其他WM_MOTOR_CONTROL_01最後階段它會拋出一個錯誤,提示「錯誤: TESTBOARD_150PC_OUT底層範圍錯誤」 (附有影片)
  4. 記錄輸出顯示

 

 

05:48:45.699184 AM [ myFirstParameterSet-Config Wizard ] - INFO -: Starting parameter conversion to counts
Trying to set "FWparamCounts_FB_CURRENTFEEDBACK_IfbkScl" to invalid value "146602"
Trying to load "FWparamCounts_FB_CURRENTFEEDBACK_IfbkScl" with invalid value "146602"
Trying to set "FWparamCounts_FB_FLUX_VoltScl" to invalid value "322008"
Trying to load "FWparamCounts_FB_FLUX_VoltScl" with invalid value "322008"
Trying to set "FWparamCounts_FB_CURRENTFEEDBACK_IfbkScl" to invalid value "146602"
Trying to load "FWparamCounts_FB_CURRENTFEEDBACK_IfbkScl" with invalid value "146602"
Trying to set "FWparamCounts_FB_FLUX_VoltScl" to invalid value "322008"
Trying to load "FWparamCounts_FB_FLUX_VoltScl" with invalid value "322008"
05:48:45.930223 AM [ myFirstParameterSet-Config Wizard ] - INFO -: Parameters have been converted to counts

 

 

注意:無論WM_MOTOR_CONTROL_01 EVAL-M1-101TF TDA5235_868_5_BOARD是否連接到 iMotion Solution Designer 軟體,都會出現此問題。

 

任何幫助擺脫這種情況都將被高度感謝。

 

謝謝

Screenshot 2024-01-14 081255.png

smartconx_target@Q!w2e3r4t5y6u7i8o9p0||/t5/Motor-Control-ICs/Problem-in-Config-Wizard-of-the-iMotion-Solution-Designer-quot-Error-Out-of/td-p/676053

5 回應
Translation_Bot
Community Manager
Community Manager
Community Manager

嗨,阿

iMotion 解決方案設計師只接受正確的參數值。

請重新檢查在 Config 精靈中設定的參數值。 然後單擊確認每組配置,如附加屏幕截圖所示。 這將讓您知道配置的值是否正確還是錯誤。

正確配置參數並驗證後,繼續進行編程。

SarkarSushru_1-1705296106331.png

希望這對您有所幫助。

如果您有任何其他查詢,請告訴我們。

謝謝

蘇什魯蒂

smartconx_target@Q!w2e3r4t5y6u7i8o9p0||/t5/Motor-Control-ICs/Problem-in-Config-Wizard-of-the-iMotion-Solution-Designer-quot-Error-Out-of/m-p/676385

0
Translation_Bot
Community Manager
Community Manager
Community Manager

當我分別單擊 IC 配置、用戶引腳配置、系統硬體配置、 WM_MOTOR_CONTROL_01控製配置或保護的“驗證”按鈕時,無論我驗證它們的順序如何,它們都會通過“綠色勾號” 。

當我驗證最後一個剩餘部分時,底層配置中的 " 錯誤 " 錯誤發生,無論它是哪個部分。 例如,如果我按以下順序點擊驗證 -> 1) 系統硬體配置 -> 2) WM_MOTOR_CONTROL_01控製配置 -> 3) 保護 -> 4) IC 配置 -> 5) 使用者引腳配置,點 1 - 4 將沒有錯誤通過,但是當我點擊數字(5)時就會出現錯誤。如果我更改順序以便在最後驗證“ WM_MOTOR_CONTROL_01控製配置”,則錯誤將在該階段出現。

GUI 甚至沒有準確地告訴我哪個參數是否配置錯誤。

smartconx_target@Q!w2e3r4t5y6u7i8o9p0||/t5/Motor-Control-ICs/Problem-in-Config-Wizard-of-the-iMotion-Solution-Designer-quot-Error-Out-of/m-p/677187

0
Translation_Bot
Community Manager
Community Manager
Community Manager

嗨,阿

這可能是由於一些錯誤的參數值導致 IC 配置和WM_MOTOR_CONTROL_01控製配置部分之間發生衝突。

 

請分享項目文件,以便我們更好地理解問題。

 

謝謝

蘇什魯蒂

smartconx_target@Q!w2e3r4t5y6u7i8o9p0||/t5/Motor-Control-ICs/Problem-in-Config-Wizard-of-the-iMotion-Solution-Designer-quot-Error-Out-of/m-p/677373

0
Translation_Bot
Community Manager
Community Manager
Community Manager

感謝您的回應。 我正在附加 iMotion 解決方案設計師項目文件夾以供您參考。

smartconx_target@Q!w2e3r4t5y6u7i8o9p0||/t5/Motor-Control-ICs/Problem-in-Config-Wizard-of-the-iMotion-Solution-Designer-quot-Error-Out-of/m-p/677930

0
Translation_Bot
Community Manager
Community Manager
Community Manager

嗨,阿

請檢查以下內容:

  • 確保系統硬體配置部分中的WM_MOTOR_CONTROL_01參數依照WM_MOTOR_CONTROL_01資料表正確配置。配置的值太低,這在建置專案時引發錯誤。
  • 檢查設定的最大速度和最小速度值是否以 RPM 為單位(不是計數)。

如果您仍然面臨這個問題,請告訴我們。

另外,請分享WM_MOTOR_CONTROL_01資料表,以便我們進行驗證。

謝謝

蘇什魯蒂

smartconx_target@Q!w2e3r4t5y6u7i8o9p0||/t5/Motor-Control-ICs/Problem-in-Config-Wizard-of-the-iMotion-Solution-Designer-quot-Error-Out-of/m-p/678392

0