Tip / ログイン to post questions, reply, level up, and achieve exciting badges. Know more

cross mob
Translation_Bot
Community Manager
Community Manager
Community Manager

こんにちは

最新のDebian OS 64Bit(Debian GNU/Linux 12 (bookworm))を搭載したRaspberry Pi 4で MULTICH_CONNECT_PCB BGT60TR13Cしようとしています。 このOSバージョンのホイールファイルがないため、ドキュメントに従って作成しようとしましたが、次のエラーが発生しました。 RADAR_SPEED_MONITOR開発KIT_A2G_TC387_MOTORCTR(3.5.1.202310261055)をダウンロードしましたが、RADAR_SPEED_MONITORフォルダをRaspberry Piにコピーし、必要なパッケージ(CMake、SetupTools、Wheel)をインストールして、Wheelファイルの作成を試みました。サポートを探して、どんな助けでも大歓迎です。 ありがとうございます!

エラーメッセージ:

ターゲットを「wheel-ifxradarsdk」にするルールはありません。 止める。

DEMO BGT60TR13C 

smartconx_target@Q!w2e3r4t5y6u7i8o9p0||/t5/Radar-sensor/Unable-to-create-Python-wheel-to-connect-BGT60TR13C-Radar-to-Raspberry-Pi-4-No/td-p/666006

0 件の賞賛
1 解決策
Translation_Bot
Community Manager
Community Manager
Community Manager

こんにちはHJ2、

うまくいかないと聞いて申し訳ありませんが、Pythonホイールは64ビットOSをサポートしていません。

https://blog.piwheels.org/raspberry-pi-os-64-bit-aarch64/

ティッカー

ヤラン

 

smartconx_target@Q!w2e3r4t5y6u7i8o9p0||/t5/Radar-sensor/Unable-to-create-Python-wheel-to-connect-BGT60TR13C-Radar-to-Raspberry-Pi-4-No/m-p/669384

元の投稿で解決策を見る

0 件の賞賛
6 返答(返信)
Translation_Bot
Community Manager
Community Manager
Community Manager

こんにちはhj2、

この問題を解決するには、Raspberry Pi 4 に ifxRadarSDK に必要な依存関係をインストールする必要があります。 試すことができるいくつかの手順を次に示します。

  1. ターミナルで次のコマンドを実行して、ifxRadarSDK をインストールします。

    sudo pip3 install ifxradarsdk
    

    これにより、ifxRadarSDK に必要な依存関係がインストールされます。

  2. 問題が解決しない場合は、次のコマンドを実行してパッケージリストを更新してみてください。

    sudo apt-get update

     

  3. パッケージリストが更新されたら、次のコマンドを実行して、必要な依存関係を再度インストールしてみてください。

    sudo pip3 install ifxradarsdk
    
  4. それでも問題が解決しない場合は、必要な依存関係を手動でインストールしてみてください。

お役に立てば幸いです。

ティッカー

ヤラン

smartconx_target@Q!w2e3r4t5y6u7i8o9p0||/t5/Radar-sensor/Unable-to-create-Python-wheel-to-connect-BGT60TR13C-Radar-to-Raspberry-Pi-4-No/m-p/666051

0 件の賞賛
Translation_Bot
Community Manager
Community Manager
Community Manager

こんにちはYaran_W、

指示に従ってifxradarsdkをインストールしようとしましたが、次のエラーが発生しました。 Raspberry Pi 4 で Debian OS 64Bit (Debian GNU/Linux 12 (bookworm)) を実行しています。

「インデックスを見ると、 https://pypi.org/simplehttps://www.piwheels.org/simple
エラー:要件を満たすバージョンが見つかりませんでしたifxradarsdk(バージョンから:なし)
エラー: ifxradarsdk に一致するディストリビューションが見つかりません」

smartconx_target@Q!w2e3r4t5y6u7i8o9p0||/t5/Radar-sensor/Unable-to-create-Python-wheel-to-connect-BGT60TR13C-Radar-to-Raspberry-Pi-4-No/m-p/667116

0 件の賞賛
Translation_Bot
Community Manager
Community Manager
Community Manager

こんにちはhj2、

「wheels」パスでWHLファイルの適切なバージョンを見つけてインストールしてください。

*\RDK3.5 \ assets \ software \ RADAR_SPEED_MONITOR Sdk \ RADAR_SPEED_MONITOR Sdk \ Python_wheels

 

Yaran_W_0-1703655654326.png

ティッカー

ヤラン

 

smartconx_target@Q!w2e3r4t5y6u7i8o9p0||/t5/Radar-sensor/Unable-to-create-Python-wheel-to-connect-BGT60TR13C-Radar-to-Raspberry-Pi-4-No/m-p/667433

0 件の賞賛
Translation_Bot
Community Manager
Community Manager
Community Manager

こんにちはYara_W、

私はすでにそれを試しましたが、うまくいきませんでした、以下はエラーメッセージです。 htmlドキュメント(pg_rdk_python)には、ホイールファイルはRaspbian Buster、32ビット用であると記載されていますが、私はRaspbian Debian、64ビットを実行しています。

エラー: ifxradarsdk-3.5.0+8c595dbb-py3-none-linux_x86_64.whl は、このプラットフォームでサポートされているホイールではありません。

エラー: ifxradarsdk-3.5.0+8c595dbb-py3-none-linux_armv7l.whl は、このプラットフォームでサポートされているホイールではありません。



smartconx_target@Q!w2e3r4t5y6u7i8o9p0||/t5/Radar-sensor/Unable-to-create-Python-wheel-to-connect-BGT60TR13C-Radar-to-Raspberry-Pi-4-No/m-p/667805

0 件の賞賛
Translation_Bot
Community Manager
Community Manager
Community Manager

こんにちはHJ2、

うまくいかないと聞いて申し訳ありませんが、Pythonホイールは64ビットOSをサポートしていません。

https://blog.piwheels.org/raspberry-pi-os-64-bit-aarch64/

ティッカー

ヤラン

 

smartconx_target@Q!w2e3r4t5y6u7i8o9p0||/t5/Radar-sensor/Unable-to-create-Python-wheel-to-connect-BGT60TR13C-Radar-to-Raspberry-Pi-4-No/m-p/669384

0 件の賞賛
Translation_Bot
Community Manager
Community Manager
Community Manager

こんにちはYaran_W、

サポートのおかげで、32ビットに切り替えてラッパーをインストールすることができました。

smartconx_target@Q!w2e3r4t5y6u7i8o9p0||/t5/Radar-sensor/Unable-to-create-Python-wheel-to-connect-BGT60TR13C-Radar-to-Raspberry-Pi-4-No/m-p/670403

0 件の賞賛