How to setup a development
environment for XMC™

microcontrollers

This document describes the steps to setup a development environment for XMC™ microcontrollers

running in Windows, Linux and Mac OS X using free available tools.

GCC ARM Embedded Tool Chain
Download and install GNU ARM GCC toolchain

https://developer.arm.com/open-source/gnu-toolchain/gnu-rm/downloads

Horme / Linux and Gpen Source / GNU Toolchain / GNU ARM Emnbedded Toolchain / Dewnloads

GNU ARM Embedded Toolchain

Overview Downloads

Downloads

The GNU Embedded Toolchain for ARM s a ready-to-use, open source suite of tools for C,
C++ and Assembly pregramming targeting ARM Cortex-M and Cortex-R family of
processors. It includes the GNU Compiler (GCC) and is available free of charge directly from
ARM for embedded software development on Windows®, Linux and Mac OS® X operating
systems. Follow the links on this page to download the right version for your development
environment.

B GNU ARM Embedded Toolchain: 6-2017-q1-update  February 23, 2017

GNU ARM Embedded Toolchain

Version 6-2017-q1-update
Released: February 23, 2017

Download ~

Download

(81.80 MB)

What's new in 6-2017-q1-update Windows 32-bit
File: gec-arr bi
Features: Windows ZIP

File: gre-arm-none-eabi-4-2017-g1-update-win32-zip.zip (124.26 MB)

o All GCC & features, plus latest mainline feature: R B
. . . . . Linux &4-bit
+ Full ARMvE-M suppeort including atomics and Security Extensions

17-q1-updd

Download

Download

+ ARM PURECCDE support for ARMv7-M and ARMy8-M Mainline
+ Co-processor intrinsics support
+ Cortex-M?3 and Cortex-M33 sunport

File: gee-arm-none-eabi-6-2017-q1-update-linuxtar.bz2 (95.60 MB)

Mac OS X 64-bit
File: gee-arm-none-eabi-6-2017-g1-update-mac.tar.bz2 (99,34 ME)

Download



https://developer.arm.com/open-source/gnu-toolchain/gnu-rm/downloads

2. Eclipse IDE
Download and install Eclipse for C/C++ from
http://www.eclipse.org/downloads/packages/eclipse-ide-cc-developers/neon2

Open eclipse and create a new workspace.

3. GNU ARM Eclipse Plugin
Download the latest version of the plugin from
https://github.com/gnuarmeclipse/plug-ins/releases

In eclipse, go to Help>Install New Software... and click on Add..., select Archive and browse to
the previous downloaded file. Check all items and click on Next

i
Available Software

Check the ibems that you wish to install, N\
B
Work with: | GNU ARM Eclipse repositary - jar:file:/C:/Temp/ilg.gnuarmeclipse. repository-3,3.1-201702251311.zip j Add...

Find more software by working with the "Avallable Software Sites" preferences.

[trne Fier ket

Name [ wersion [
= [Z000 GHU ARM CfC++ Cross Development Tools
L5 GMU ARM CC++ ADUCMB3E0 Project Template 1.1.3.201702251311
[Fl < GMU BRM C/C+-+ CodeRed Debug Perspective 1.1.1.201702251311
[FI5F GNU ARM CJC++ Cross Compiler 2.3.1,201 702251311
[F 45 GNU ARM CJC++ Dacumentation (Placsholder) 1.1.1.201702251311
[ GMU BRM C/C++ Freescale Project Templates 2.2.7.201 702251311
[E1 4+ MU ARM C/C+-+ Generic Cortex-M Project Template 1.3.1.201702251311
[F1 55 &MU ARM C/C++ J-Link Debugging 413,201 702251311
[ 45 N ARM C/C++ OpenoCD Debugaing 4.1,3.201 702251311
[F < MU BRM C/C++ Packs (Experimental) 2.2.2.201 702251311
[F1 5 GNU ARM C/C++ PyOCD Debugging 1.1.2.201702251311
[F1 45 &MU ARM CfC++ QEMU Debugging 3.1.3.201702251311
[l 55 MU BRM C/C+-+ STM32Fx Project Templates 2.6.1.201 702251311

Select Al Deselect Al 12 items selected

Under windows you will need also tools for building the projects using make
https://github.com/gnuarmeclipse/windows-build-tools/releases

4. CMSIS Pack Plugin
Download the latest version of the plugin from
https://github.com/ARM-software/cmsis-pack-eclipse/releases

In eclipse, go to Help>Install New Software... and click on Add..., select Archive and browse to
the previous downloaded file. Check all items and click on Next

Setup the Packages folder path in the Preferences eclipse menu as shown in the next
pictures.


http://www.eclipse.org/downloads/packages/eclipse-ide-cc-developers/neon2
https://github.com/gnuarmeclipse/plug-ins/releases
https://github.com/gnuarmeclipse/windows-build-tools/releases
https://github.com/ARM-software/cmsis-pack-eclipse/releases
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5. Install CMSIS Software Packs
1. Make the C/C++ Packs perspective visible.
2. Update the packages definitions from all repositories.
3. Select the CMSIS Software packs, i.e. select CMSIS, XMC4000_DFP and XMC1000_DFP
entries holding CTRL key down.
4. |Install a local copy of the selected packages.

im ws_cmsis_packs - Pacics - Echpse.
v

ARM Cortex M
AR Corterc MO phis
AR Corte M3
AR Corte M
AEM Cortex M7
AR Cortex M23
AR Cortex MI3
ARM S2000

ARM SZ300
ARMVG-M Bassine
ARMG-M Marine

st anvnd)
CHSI5-Orrver Vobdation

Bundieof FreeRTOS for CortexcH and Cortexc

CMSIS-RTOS Vabdation

ARM e Chen for Corter M davices

REM e Cryplogyphic a8 SSUTLSlonary o Cortere M devices
mbed 05 Scheduer for Cortex-M devies

H
B wsscn Sewister
@ CMSIS | CORE
@ Device | Startup
® @ Device | Startup | € Startup
® # Infimon @ Device | Startup
® Sihcon Labs # # TLE4x OFP Infirecn TUESS4x Sévid Device SLOPort @ Device | Startup | C Startup.
- SONX ® i TLESSEx_DFP Infinecn TUES@6x Saries Device Support @ Device | Startup
® @& Soarskn ® i TLESRe OFP Infinecn TLESS7x Series Device Suppert i @ Davee f Saetup | C St
v S TMKPOBCLI OFecs ® # aMCI000_0FP (nstalled)  Infinecn XMC1000 Series Device Support, Drivers and Examples @ Device [ St
Texas Insteuments. # @ MMCH000_DFP (instaled)  Infineon XMC4000 Series Device Support, Drivers. and Examples @ Device | Startup | C Startup
s . g
® (> sy B wp @ Devics | Startup | € Startup
® 5 madatek @ Device | Startup
Lo e
% L% MindMotion =l @ Do | St
= @ Device | Startup | C Startup
=] @ Devea | Satip
@ Device | Startup | C Startup
@ Device | Startup
@ Device | Startup | € Startup
@ Device [ Startup
@ Device | Startup | € Startup
6. Install J-LInk debugger software
Download and install the latest version from
https://www.segger.com/downloads/jlink
63 3-Link Software and Documentation Pack E

All-in-one debugging salution
Can be downloaded and used fres of charge by any owner of 3 SEGGER J-Link, 1-Trace, Flasher ARM or Flasher R madal.
Mot all features of it may be available on all J-Link / 3-Traee / Flasher models

Updated frequantly

Release Motes

More information

X Click for downloads

[ J-Link Software and Documentation pack for Windaws v6.14b 24,015 KB B
Installing the software will autematically install the J-Link USB drivers and  older versions  [2017-03-09]
offers to update applications which use the J-Link DLL, Multiple versions of
the 3-Link softwars can be installed on the same PC withaut problams; they
will co-exist in different directaries. Mare..,

¥ Download

[# )-Link Software and Documentation pack for MacOSx WE.14b 41,966 KB

¥ Download X
Older versions  [2017-03-09]

[ J-Link Software and documnentation pack for Linux, DEB Installer, 32-bit W6.14b 10,523 KB G

¥ Download
Older versions  [2017-03-09]

[ J-Link Software and Documnentation pack for Linux, DEB Installer, 64-bit v614b 16,878 KB 0

¥ Download X
Older versions  [2017-03-09]

[ J-Link Software and Docurnentation pack for Linux, RPM Installer, 32-bit W6.14b 10,530 KB G

¥ Download
Older versions  [2017-03-09]

%D — [# 1-Link Software and Documentation pack for Linux, RPM Installer, 84-bit v614b 14,001 KB 0\
ownload

Older versions  [2017-03-09]

& Download [ 3-Link Software and Docurnentation pack for Linux, TGZ archive, 32-bit ¥6.14b 10,601 KB G

Older versions  [2017-03-09]

%D — [# I-Link Software and Documentation pack for Linux, TGZ archive, 64-hit v6.14b 16,557 KB 0
ownload

Older versions  [2017-03-09]

¥ D load [ J-Link Software and Documentation pack for Linux ARM systems VE.14b 10,438 KB G

Ll Note: This packages is anly nesdsd in the special case of J-Link being Older versions  [2017-03-09]

controlled by a Linux system which is running on an ARM hardware (so
J-Link is connected via USB/Ethernet to this ARM system that is running
Linux). In case 1-Link is just connected to a PC running Linux, the "1-Link
software & documentation pack for Linux" is the correct package,

Note: This package comes without any support.

Alternatively you can also use OpenOCD
https://github.com/gnuarmeclipse/openocd/releases



https://www.segger.com/downloads/jlink
https://github.com/gnuarmeclipse/openocd/releases

Install Ozone debugger
Download and install the latest version from
https://www.segger.com/downloads/jlink
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When creating a new project in Ozone, a peripheral description file (SVD) is optionally
required. The files for each of the XMC™ microcontroller family members can be found at in
the SVD folder in the XMC4000_DFP or XMC1000_DFP installation as shown below.

k Debugger ¥2.30a - New Proj =13l x|
File Edit Wiew Debug Help
|~k a ¥ &
Functions X Registers X

”New Project Wizard x| |

- Work - workspaces = Packages - Infineon - XMC4000_DFP - 2,7,1 ~ SYD - ml Search SYDr

Mo target connection

Organize »  Mew folder = -~ [
- N ) .
¢ Favarites =1 Mame | Date modified | Type I Size: I
B Desktop || ¥Mc4100.5vd 3(21/20175:20PM SWDFile 2,445 KB
4 Downiloads || ¥MC4200.5vd 3§21/2017 5:20 FM WD File 2,445 KB
&l recent Pl
w4 Recent Hares [ #4300, 5vd 3/20/2017 5:20FM SWDFils 2,697 KB
=5 Liraries || #mc4400,5vd 3(21/2017 5:20PM SWDFile 3,081 KB
7 Documents || #mcas00.svd 3212017 5:20PM WD Fe 3,432 KB
=71 i KMC4700.5vd 3(21/20175:20PM SWDFile 3,574 KB
Mermary 1 J’ Music
[&=] Pictures
=1 subversion e
B videos
;-;_/ Compuker
Mo barget connection S Systembisk (T2
¥ Ferreije (\\MUCSDI‘\;I
File narme: |xmc4euu‘wd =] [sed Files cr.sua iy
|Ready | Ln0 ch | Disconnecked -



https://www.segger.com/downloads/jlink

8. Creating a project
1. In eclipse, click File>New>Project, select C Project.
2. Give a name to the project
3. Select CMSIS C/C++ Project as Project type.
4. Click Next
1ol
C Project

Create C project of selected tvpe

Project name: | test

V¥ Use default location
[ ocation; |C:'|,W0rk'l,workspaces'l,ws_cmsisyacks'l,test Browse. .. |

Choose file system: IdeFauIt "l

Project bvpe: Taoolchains:
[F-[= GNU Autotools - Cross ARM GCC
Eb Executable Cross GICC
Empty Project Cygwin GCC
Hello \World ANSI C Project MinGW GCC

CMSIS CJC++ Project
Hella world ARM C Praject
ADUCM 36 CfC++ Project

-~ @ Hello World ARM Cortex-m ci:ll|
4] | >

v Show project kypes and toolchains only if they are supported on the platForm

® < Back. I Mexk = I FEimishi | Cancel |

5. Inthe next dialog enable the creation of default main.c. Click Next.

Il
CMSIS CfC++ Project

Selected project bype: Executable

Cukpuk; EXE

~ Taolchain Adapter
Taolchain: Cross ARM GCC
fdapter: |Cross ARM GCC Toolchain Adapter |
Family: GCC | (passed model via Tcompiler filker attribute)

Toolchain Adapter for GNU ARM C/C++ Cross Campiler

IV Create default main.c file

@ <Back [ mextz | At Cancel




6. Inthe next dialog, select the device and click next

=lolx|
Selact Device .
Device:  WMC4800-F144x2048 CPL: ARM Cortex-M4
wendor:  Infineon Max. Clock: 144 MHz
Pack:  Infineon. XMC4000_DFP.2.7.1 IMematy: 351 kE RAM, 4 MB ROM

URL: hitbp: fivava. keil. com/ddZ finfineon«me4a00 1442048 FRU: Isingle precision

]
Search: | Endian: ILittIa—end\an j
=

=% ¥mC4000

T4 ¥MC4100 Series
T4 ¥MC4200 Series
T4 ¥MC4300 Series
T4 ¥MC4400 Series
1§ ¥MC4S00 Series

The XMZ4000 Family marks a cornerstone in microcontroller design For
real-time critical systems, With XMC4000 Infinean combines its leading-sdge
peripheral set with an industry-standard ARME Cortex™-M4 core, Featuring
Infineon’s poveerful peripheral set, configurable to specific application
requirements, XMC4000 is the ultimate chaice For today’s industrial control
solutions, This Family is designed ko tackle the imminent challenges of
improving energy efficiency, supporting advanced communication pratocals,

and reducing time-to-market. Family members operate even in high-temperature
+-1§ ¥MC4700 Series environments of up ko 125 °C, granting you access to their exceptional performance
E1-“1% ¥MC4E00 Series in all carmers aof your system.

- sMC4B00-E196x1024
- xMC4B00-E196x1536
-l #MaENn-E1 964
B mcasno-Fiooxinze
B mcasn0-Fiooxi536
B ¥MCaB00-F100x2045
B vcasn0-Fi4axinze
B vc4asn0-Fi44x1536

1<l
L

O < Back I Next = I Finisty Caneel

7. Inthe next dialog crosscheck that the GNU GCC ARM is detected correctly. Click Finish.
—lolx|
Cross GNU ARM Toolchain

Select the toolchain and configure path |

Toolchain name: I GMU Tools For 8RM Embedded Processors {arm-none-eabi-goc)

Toolchain path: | C:fProgram Files (x&6)/GMU Tools ARM Embedded|é 2017-q1-update bin

< Back et 2= | Firish I Cancel




8. At this point you should see the RTE configuration page. Make the selections as shown

below, click on resolve button to satisfy dependencies and save the changes.

& testrteconfi 52 [g] mainc €] RT%_Conf_cM.c

4 Components [+ Resclve

=

4 CMSIS Driver
B 4 Device

Unified Device Drivers compliant bo CMSIS-Driver Specifications

Startup, System Setup

Software Components | Sel. | ‘ariant | Yendor Wersion | Description -
M EMC4800-F144x2045 Infingon ARM Cortex-4 144 MHz, 351 kB RAM, 4 MB ROM
= € Board Support %MC4800 Relax Kit  Infineon 1.0.1 , ¥MC4800 Relax Kit Board Support
@ Buttons O Button driver For XMC4300 Relax Kit
¥ LED (] LED driver for XMC4800 Relax Kit
B 4 M3Is Cortex Micraconkroller Software Interface Components
¥ CORE ARM 5.0.1 ., SMSIS-CORE For Cartex-M, SC000, SC300, ARMyE-M
@ DsP ] ARM 151 , CMSIS-DSP Library for Cortex-M, SC000, and SC300
= & RTOS(APT) 1.0.0  SMSIS-RTOS APT For Corbesx-M, SC000, and SC300
@ Keill RT= L ARM +4.81.0 , CMSIS-RTOS RTY implementation For Corbex-M, SC000, and 5300
W Keill RT2S O ARM 5.1.0 , TMSIS-RTOS RTXS implementation For Cartex-M, SCO00, and SC300
¥ RTOS2 (APL} 2.1.0 _ CMSIS-RTOS API for Corkex-M, SC000, and 5C300

# RTE_ Device O Infingon 1.1.0 . RTE Device
@ Startup Infineon 2.0.0 , System Startup for Infineon XMC4000 Family
= @ XMl
@ CAN (] Infingon 2.1.8  Controller area network (CAN) driver For XMC4000
@ CCU4 O Infineon 218 ., Capbure Compare Unit 4 (CCU4) driver For $MC4000
@ CCus (] Infingon 2.1.8 , Capture Compare Unit & (CCUS) driver For $MC4000
w DAC O Infineon 218 , Digital ko Analog Converter (DAC) driver For XMC4000
@ DMA (] Infingon 2.1.8 , Direct Memory Access (DAY driver for XMC4000 | |
W DsD O Infineon 218 , Delta Sioma Demodulator (D50 driver For #MC4000
¥ EBU (] Infingon 2.1.8 P External Bus Interface (EBU) driver for XMC4000
i ECAT ] Infingon 2138 , EtherCAT (ECAT) driver for 2MC4000
@ ERU [m] Irfineon 218  Exert Request Urit (ERUI) driver For #MC4000
@ ETH_MAC ] Infingon 2138 , Ethernet MAC (ETH MAC) driver for XMC4000
@ FCE [m] Irfineon 218 , Flexible CRC Enaine (FCE) driver for ¥MC4000
¥ FLASH O Infineon 2.1.8 Flash Driver (FLASH) driver For XMC4000
T "
@ HRPWM O Infingon 2.1.8 , High Resolution PwM (HAPWM) driver for XMC4000 ﬂ
- =] - i e b mmbn TR Pl lommarim m AAEFTA duimo o A= AP
Walidation Output | Description [

CumponentsJ Device | Packs |

9. The CMSIS RTOS RTX Pack need to be configured. Open the file RTX_Conf_CM.c and

change the OS_CLOCK to 144000000. This the default frequency of the XMC4800 after

initialization.

10. Open main.c file, and make the modifications as below.

#ifdef RTE_
#include "RTE_ Components.h"
#endif
#ifdef RTE_CMSIS_RTOS
#include "cmsis os.h"
#endif

#include "xmc gpio.h"

#define LED1 P5_9
#define LED2 P5_8

void Thread 1(void const *arg);
Thread 1
osThreadDef (Thread 1, osPriorityNormal,

void Thread 1(void const *arg)

{

while (true)

{
XMC_GPIO ToggleOutput (LEDI1) ;
XMC GPIO ToggleOutput (LED2) ;

osDelay (1000) ;

1,

// Component selection

// when RTE component CMSIS RTOS is used
// CMSIS RTOS header file

0);

// function prototype for

// define Thread 1



/* main function */
int main(void)

{

#ifdef RTE CMSIS RTOS // when using CMSIS RTOS
osKernellInitialize (); // initialize CMSIS-RTOS
#endif

/* Initialize device HAL here */

XMC GPIO CONFIG t gpio config;

gpio_config.mode = XMC GPIO MODE OUTPUT PUSH PULL;
gpio_config.output level = XMC_GPIO_OUTPUT_LEVEL_HIGH;

XMC_GPIO_ Init (LED1, &gpio config);

gpio_config.output level = XMC GPIO OUTPUT LEVEL LOW;
XMC GPIO Init (LED2, &gpio config);

osThreadCreate (osThread(Thread 1), NULL);

#ifdef RTE_CMSIS_RTOS // when using CMSIS RTOS
// create 'thread' functions that start executing,
// example: tid name = osThreadCreate (osThread(name), NULL);
osKernelStart (); // start thread execution
#endif

/* Infinite loop */
while (1)
{
/* Add application code here */

}

11. Compile and download the code and debug your code. You can use the GDB client
included in eclipse following the instructions found at
http://gnuarmeclipse.github.io/debug/.

Alternatively you can use the previously installed Ozone debugger. Please refer to the

instruction in the user manual.

Other tools
XMC™ Flasher
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